609dccc1fd
has been linking with Apple's CommonCrypto instead. Add an "apple-common-crypto" option that explicitly avoids CommonCrypto when it's off. Turn it off by default, and set PKG_FAIL_REASON if it's enabled on an unsuitable system. While here, regenerate fuzzy patches. Addresses pkg/49051. Bump PKGREVISION.
17 lines
740 B
Text
17 lines
740 B
Text
$NetBSD: patch-ac,v 1.2 2014/08/01 19:18:39 schmonz Exp $
|
|
|
|
--- gitk-git/Makefile.orig 2014-05-30 21:38:10.000000000 +0000
|
|
+++ gitk-git/Makefile
|
|
@@ -50,9 +50,9 @@ endif
|
|
all:: gitk-wish $(ALL_MSGFILES)
|
|
|
|
install:: all
|
|
- $(INSTALL) -m 755 gitk-wish '$(DESTDIR_SQ)$(bindir_SQ)'/gitk
|
|
- $(INSTALL) -d -m 755 '$(DESTDIR_SQ)$(msgsdir_SQ)'
|
|
- $(foreach p,$(ALL_MSGFILES), $(INSTALL) -m 644 $p '$(DESTDIR_SQ)$(msgsdir_SQ)' &&) true
|
|
+ $(BSD_INSTALL_SCRIPT) gitk-wish '$(DESTDIR_SQ)$(bindir_SQ)'/gitk
|
|
+ $(BSD_INSTALL_DATA_DIR) '$(DESTDIR_SQ)$(msgsdir_SQ)'
|
|
+ $(foreach p,$(ALL_MSGFILES), $(BSD_INSTALL_DATA) $p '$(DESTDIR_SQ)$(msgsdir_SQ)' &&) true
|
|
|
|
uninstall::
|
|
$(foreach p,$(ALL_MSGFILES), $(RM) '$(DESTDIR_SQ)$(msgsdir_SQ)'/$(notdir $p) &&) true
|