b7adfdb4f4
Git is a free and open source distributed version control system designed to handle everything from small to very large projects with speed and efficiency. Git is easy to learn and has a tiny footprint with lightning fast performance. It outclasses SCM tools like Subversion, CVS, Perforce, and ClearCase with features like cheap local branching, convenient staging areas, and multiple workflows. This package contains only the git program (and subcommands). It does not contain man pages or the tk-based repository browser.
30 lines
996 B
Text
30 lines
996 B
Text
$NetBSD: patch-ag,v 1.1 2013/09/09 13:54:44 wiz Exp $
|
|
|
|
--- templates/Makefile.orig 2010-10-22 03:49:16.000000000 +0000
|
|
+++ templates/Makefile
|
|
@@ -8,7 +8,7 @@ INSTALL ?= install
|
|
TAR ?= tar
|
|
RM ?= rm -f
|
|
prefix ?= $(HOME)
|
|
-template_instdir ?= $(prefix)/share/git-core/templates
|
|
+template_instdir = ${GIT_TEMPLATE_INSTDIR}
|
|
# DESTDIR=
|
|
|
|
ifndef SHELL_PATH
|
|
@@ -39,7 +39,7 @@ boilerplates.made : $(bpsrc)
|
|
case "$$boilerplate" in *~) continue ;; esac && \
|
|
dst=`echo "$$boilerplate" | sed -e 's|^this|.|;s|--|/|g'` && \
|
|
dir=`expr "$$dst" : '\(.*\)/'` && \
|
|
- mkdir -p blt/$$dir && \
|
|
+ $(BSD_INSTALL_DATA_DIR) blt/$$dir && \
|
|
case "$$boilerplate" in \
|
|
*--) continue;; \
|
|
esac && \
|
|
@@ -61,6 +61,6 @@ clean:
|
|
$(RM) -r blt boilerplates.made
|
|
|
|
install: all
|
|
- $(INSTALL) -d -m 755 '$(DESTDIR_SQ)$(template_instdir_SQ)'
|
|
+ $(BSD_INSTALL_DATA_DIR) '$(DESTDIR_SQ)$(template_instdir_SQ)'
|
|
(cd blt && $(TAR) cf - .) | \
|
|
(cd '$(DESTDIR_SQ)$(template_instdir_SQ)' && umask 022 && $(TAR) xof -)
|