8e392f54d0
The one test remaining I've not been able to figure out what goes wrong (it tries overriding the compiler to use, but ends up passing the source to cc anyway, which wasn't supposed to happen). Updated DESCR to be a little more verbose. It now starts with GYP is a tool for the Chromium project that generates native Visual Studio, Xcode and SCons and/or make build files from a platform-independent input format. Other changes: * Substitute /usr/bin/python and a bare "python" in a couple of files * Replace python in the interpreter line in all *.py files, done in a separate Makefile.replalce-python due to its size * Add a tool.mk make fragment for pkgsrc, for users of "gyp" within pkgsrc. It makes a "python" available, via the python package's own tool.mk. The GYP language spec says it's kosher to invoke Python from a gyp file by just saying "python". * Fix the bash interpreter in the "gyp" script * Add config for "netbsd7" as well * For some reason "thin" ar archives sometimes fail to produce an archive which "ar t" recognizes as valid, so avoid using them on NetBSD * Fix up some of the tests; our GNU make says "nothing to be done" with different quotes, add NetBSD platform support in some tests, and regenerate a couple of output files (should have been done upstream). PKGREVISION bumped.
33 lines
1.5 KiB
Python
33 lines
1.5 KiB
Python
$NetBSD: patch-test_lib_TestGyp.py,v 1.1 2014/08/21 14:49:43 he Exp $
|
|
|
|
Our gnu make says "Nothing to be done" with just single quotes.
|
|
|
|
--- test/lib/TestGyp.py.orig 2014-07-14 14:19:50.000000000 +0000
|
|
+++ test/lib/TestGyp.py
|
|
@@ -640,7 +640,7 @@ class TestGypAndroid(TestGypBase):
|
|
"""
|
|
Verifies that a build of the specified target is up to date.
|
|
"""
|
|
- kw['stdout'] = ("make: Nothing to be done for `%s'." %
|
|
+ kw['stdout'] = ("make: Nothing to be done for '%s'." %
|
|
self.target_name(target))
|
|
|
|
# We need to supply a custom matcher, since we don't want to depend on the
|
|
@@ -784,7 +784,7 @@ class TestGypMake(TestGypBase):
|
|
message_target = 'all'
|
|
else:
|
|
message_target = target
|
|
- kw['stdout'] = "make: Nothing to be done for `%s'.\n" % message_target
|
|
+ kw['stdout'] = "make: Nothing to be done for '%s'.\n" % message_target
|
|
return self.build(gyp_file, target, **kw)
|
|
def run_built_executable(self, name, *args, **kw):
|
|
"""
|
|
@@ -1198,7 +1198,7 @@ class TestGypXcode(TestGypBase):
|
|
"PhaseScriptExecution /\\S+/Script-[0-9A-F]+\\.sh\n"
|
|
" cd /\\S+\n"
|
|
" /bin/sh -c /\\S+/Script-[0-9A-F]+\\.sh\n"
|
|
- "(make: Nothing to be done for `all'\\.\n)?")
|
|
+ "(make: Nothing to be done for 'all'\\.\n)?")
|
|
|
|
strip_up_to_date_expressions = [
|
|
# Various actions or rules can run even when the overall build target
|