pkgsrc/lang/ocaml/patches/patch-lex_Makefile
jaapb 1f583dbce3 Updated lang/ocaml to version 4.14.0.
This is a long-overdue update, so there are many changes. Details are in
the Changes file in the distribution.

The mk/ocaml file will be moved to lang/ocaml and the logic for selecting
whether to use the native-code compiler will be factored out into
native.mk to avoid duplications.

This is the final version before OCaml 5.0 arrives, which has
multicore support and should be a major change from the 4.x versions.
2022-05-24 18:25:38 +00:00

24 lines
789 B
Text

$NetBSD: patch-lex_Makefile,v 1.4 2022/05/24 18:25:38 jaapb Exp $
Honor LDFLAGS.
--- lex/Makefile.orig 2021-09-30 15:40:11.000000000 +0000
+++ lex/Makefile
@@ -31,7 +31,7 @@ CAMLC = $(BOOT_OCAMLC) -strict-sequence
CAMLOPT = $(OCAMLRUN) $(ROOTDIR)/ocamlopt$(EXE) -nostdlib -I $(ROOTDIR)/stdlib
COMPFLAGS = -absname -w +a-4-9-41-42-44-45-48-70 -warn-error +A \
-safe-string -strict-sequence -strict-formats -bin-annot
-LINKFLAGS =
+LINKFLAGS = -cclib "$(LDFLAGS)"
CAMLDEP = $(BOOT_OCAMLC) -depend
DEPFLAGS = -slash
DEPINCLUDES =
@@ -52,7 +52,7 @@ ocamllex$(EXE): $(OBJS)
$(CAMLC) $(LINKFLAGS) -compat-32 -o $@ $^
ocamllex.opt$(EXE): $(OBJS:.cmo=.cmx)
- $(CAMLOPT_CMD) -o $@ $^
+ $(CAMLOPT_CMD) $(LINKFLAGS) -o $@ $^
clean::
rm -f $(programs) $(programs:=.exe)