pkgsrc/lang/ocaml/patches/patch-man_Makefile
jaapb 1f583dbce3 Updated lang/ocaml to version 4.14.0.
This is a long-overdue update, so there are many changes. Details are in
the Changes file in the distribution.

The mk/ocaml file will be moved to lang/ocaml and the logic for selecting
whether to use the native-code compiler will be factored out into
native.mk to avoid duplications.

This is the final version before OCaml 5.0 arrives, which has
multicore support and should be a major change from the 4.x versions.
2022-05-24 18:25:38 +00:00

14 lines
471 B
Text

$NetBSD: patch-man_Makefile,v 1.5 2022/05/24 18:25:38 jaapb Exp $
Use BSD_INSTALL_* instead of mkdir and cp
--- man/Makefile.orig 2022-02-08 16:50:12.000000000 +0000
+++ man/Makefile
@@ -22,5 +22,5 @@ MANPAGES = $(addsuffix .1,\
.PHONY: install
install:
- $(MKDIR) $(INSTALL_PROGRAMS_MAN_DIR)
- $(INSTALL_DATA) $(MANPAGES) $(INSTALL_PROGRAMS_MAN_DIR)
+ $(BSD_INSTALL_MAN_DIR) $(INSTALL_PROGRAMS_MAN_DIR)
+ $(BSD_INSTALL_MAN) $(MANPAGES) $(INSTALL_PROGRAMS_MAN_DIR)