pkgsrc/x11/libxkbui/patches/patch-ab
bjs 5547e379ed libxkbui does not depend on libXt (as per Matthieu Herrb). Thus,
remove this depedency from Makefile, b3.mk, configure scripts,
and xkbui.pc.in.  Bump Rev.
2007-11-23 14:34:33 +00:00

65 lines
2.7 KiB
Text

$NetBSD: patch-ab,v 1.1 2007/11/23 14:34:34 bjs Exp $
Follow patch-aa's lead.
--- configure.orig 2006-04-26 16:00:02.000000000 -0400
+++ configure
@@ -18758,12 +18758,12 @@ if test -n "$PKG_CONFIG"; then
pkg_cv_XKBUI_CFLAGS="$XKBUI_CFLAGS"
else
if test -n "$PKG_CONFIG" && \
- { (echo "$as_me:$LINENO: \$PKG_CONFIG --exists --print-errors \"x11 xt xkbfile\"") >&5
- ($PKG_CONFIG --exists --print-errors "x11 xt xkbfile") 2>&5
+ { (echo "$as_me:$LINENO: \$PKG_CONFIG --exists --print-errors \"x11 xkbfile\"") >&5
+ ($PKG_CONFIG --exists --print-errors "x11 xkbfile") 2>&5
ac_status=$?
echo "$as_me:$LINENO: \$? = $ac_status" >&5
(exit $ac_status); }; then
- pkg_cv_XKBUI_CFLAGS=`$PKG_CONFIG --cflags "x11 xt xkbfile" 2>/dev/null`
+ pkg_cv_XKBUI_CFLAGS=`$PKG_CONFIG --cflags "x11 xkbfile" 2>/dev/null`
else
pkg_failed=yes
fi
@@ -18776,12 +18776,12 @@ if test -n "$PKG_CONFIG"; then
pkg_cv_XKBUI_LIBS="$XKBUI_LIBS"
else
if test -n "$PKG_CONFIG" && \
- { (echo "$as_me:$LINENO: \$PKG_CONFIG --exists --print-errors \"x11 xt xkbfile\"") >&5
- ($PKG_CONFIG --exists --print-errors "x11 xt xkbfile") 2>&5
+ { (echo "$as_me:$LINENO: \$PKG_CONFIG --exists --print-errors \"x11 xkbfile\"") >&5
+ ($PKG_CONFIG --exists --print-errors "x11 xkbfile") 2>&5
ac_status=$?
echo "$as_me:$LINENO: \$? = $ac_status" >&5
(exit $ac_status); }; then
- pkg_cv_XKBUI_LIBS=`$PKG_CONFIG --libs "x11 xt xkbfile" 2>/dev/null`
+ pkg_cv_XKBUI_LIBS=`$PKG_CONFIG --libs "x11 xkbfile" 2>/dev/null`
else
pkg_failed=yes
fi
@@ -18800,14 +18800,14 @@ else
_pkg_short_errors_supported=no
fi
if test $_pkg_short_errors_supported = yes; then
- XKBUI_PKG_ERRORS=`$PKG_CONFIG --short-errors --errors-to-stdout --print-errors "x11 xt xkbfile"`
+ XKBUI_PKG_ERRORS=`$PKG_CONFIG --short-errors --errors-to-stdout --print-errors "x11 xkbfile"`
else
- XKBUI_PKG_ERRORS=`$PKG_CONFIG --errors-to-stdout --print-errors "x11 xt xkbfile"`
+ XKBUI_PKG_ERRORS=`$PKG_CONFIG --errors-to-stdout --print-errors "x11 xkbfile"`
fi
# Put the nasty error message in config.log where it belongs
echo "$XKBUI_PKG_ERRORS" >&5
- { { echo "$as_me:$LINENO: error: Package requirements (x11 xt xkbfile) were not met:
+ { { echo "$as_me:$LINENO: error: Package requirements (x11 xkbfile) were not met:
$XKBUI_PKG_ERRORS
@@ -18818,7 +18818,7 @@ Alternatively, you may set the environme
and XKBUI_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.
" >&5
-echo "$as_me: error: Package requirements (x11 xt xkbfile) were not met:
+echo "$as_me: error: Package requirements (x11 xkbfile) were not met:
$XKBUI_PKG_ERRORS