pkgsrc/net/latd/patches/patch-ac
xtraeme 2dadebc2fd Updated to 1.18. Closes PR pkg/22735.
Changelog:

latd (1.17-1) unstable; urgency=low

  * Add support for a MOPRC_INTERFACE env variable.
  * Fix bug in the lastest retransmit code that screwed up
    queued connections rather badly.
  * Don't show status messages to /dev/lat ports
  * moprc is now a C++ program that uses the LATinterfaces class.
  * llogin -p only locks devices if liblockdev is found
  * Porting work for *BSD and Darwin.
    HUGE thanks to Matthew Fredette of NetBSD for all the bpf work.
  * Use autoconf to configure and build. Again Matthew Fredette did
    most of the work for this, but I added the Linux bits.

latd (1.16-1) unstable; urgency=low

  * Don't use an IP socket for finding interfaces. So now you
    can use LAT (& moprc) with a kernel that doesn't have IP.
  * Fix latcp man page (-J and -j were wrong way round)
  * llogin -L disables locking when using -p
  * latd now expires services if it doesn't receive HELLOs
  * Expand escape sequences in /etc/issue.net or /etc/issue.lat
  * Fix crash on queued connections referencing freed memory.
  * moprc now ignores duplicate messages it receives. This fixes
    odd behaviour with some Emulex targets
  * Put a timeout on CONNECT and COMMAND messages so we can resend
    them if we get no reply.
  * Check connection IDs more carefully.

latd (1.15-1) unstable; urgency=low

  * More DS90L+ fixes (keepalive message format)
  * Fix iostreams so they produce the correct output in gcc 3.0 & 2.95.
    Now I know why people really hate iostreams.
  * Use getloadavg() rather than /proc to get load average.
  * Close all FDs before forking server processes.
  * Always send an ACK for a packet with data in it.
  * llogin uses lock files for device connections

latd (1.14-1) unstable; urgency=low

  * gcc-3.0 compilation fixes in the new bits
  * Rewritten ethernet flow control
  * Increase moprc timeout a little.
  * Don't try to process zero-length packets
  * Include lat.html documentation
  * Tested on DECserver 700
  * Send "no more slots on circuit" message when closing a connection for
    that reason. Fixes reconnection on DECserver 90L+

pkgsrc changes:

	* Fix building when using gcc3
	* Use the bsd.pkg.install.mk framework to install the
          configuration file into the right place.
2003-10-21 20:55:42 +00:00

20 lines
850 B
Text

$NetBSD: patch-ac,v 1.1 2003/10/21 20:55:42 xtraeme Exp $
--- Makefile.in.orig 2003-10-20 19:18:37.000000000 +0200
+++ Makefile.in 2003-10-20 19:20:20.000000000 +0200
@@ -508,12 +508,12 @@
sysconfDATA_INSTALL = $(INSTALL_DATA)
install-sysconfDATA: $(sysconf_DATA)
@$(NORMAL_INSTALL)
- $(mkinstalldirs) $(DESTDIR)$(sysconfdir)
+ $(mkinstalldirs) $(PREFIX)/share/examples/latd
@list='$(sysconf_DATA)'; for p in $$list; do \
if test -f "$$p"; then d=; else d="$(srcdir)/"; fi; \
f="`echo $$p | sed -e 's|^.*/||'`"; \
- echo " $(sysconfDATA_INSTALL) $$d$$p $(DESTDIR)$(sysconfdir)/$$f"; \
- $(sysconfDATA_INSTALL) $$d$$p $(DESTDIR)$(sysconfdir)/$$f; \
+ echo " $(sysconfDATA_INSTALL) $$d$$p $(PREFIX)/share/examples/latd/$$f"; \
+ $(sysconfDATA_INSTALL) $$d$$p $(PREFIX)/share/examples/latd/$$f; \
done
uninstall-sysconfDATA: