de554b326a
Release Notes: http://development.openoffice.org/releases/2.2.0.html Changes: - Fix CVE-2007-0002, CVE-2007-0238, CVE-2007-0239. - field lengths of bibliography database changed. - UTF-8 encoding for dBase databases. - "Edit in SQL View..." command for database queries. - forms: date and time fields do not default to "Today" and "Now" anymore. - query/relation design: visual marker indicating the type of table/query. - advanced database setting: "Use keyword AS before table alias names". - Annoying focus behavior of OOo was fixed. - scaling in spadmin page property page deleted. - Additional options for pdf export. - Desktop-Integration package for slackware. - Show/Hide Slide menu entry split into two entries. - Support for NetBSD, Linux 64 bit, Linux SPARC in TestTool Environment. - New behavior of "Insert - Sheet From File". - Import MS Excel files with PivotTables based on external data. - Insert/Delete Note in cell context menu. - some UNO Remote Protocol (URP) changes. - Extension Dependency OpenOffice.org-minimal-version. - Export COT, ACOT, COTH, and ACOTH to MS Excel files. - System integration for extensions. - Online Update for Extensions. - Localization of UNO Dialogs. - OOo no longer generates sensitive UUIDs. - Autokerning enabled by default. - CVS import dialog for unformatted clipboard text. - Ordinal suffix in AutoFill. - simple protocolhandler add-on support in uno-skeletonmaker. - Autokerning enabled by default. - Create Tango icon set for OO.o. - Add localisation support to UNO dialogs and IDE Dialog Editor. - extend add-on support in the uno-skeletonmaker. - Upgrade icu to latest version. - Implement an optional help section in the ObjectInspector. - additional PDF export features - makes localize.sdf files optional. - Add/update Slovenian templates for 2.1. - update of icons. - changes for soffice script. - implement shaped system windows. - Updates of OOo <-> ATK bridge. - #139464# use #REF! errors in formulas using cells from missing external linked sheets. - Tooling fixes for CWS and MWS handling. - Remove SISSL from module filter. - make the 'automatic update check' more consistent. - code only cws, adds infrastructure for vba interop project. - Prepare framework code to support inplace active objects that are not UIactive. - Some bugs, some very minor UNO runtime features. - Changed context menu (insert/delete note) for Calc cells. - new buildsystem features. - Improve line height compatibility on UNX platforms while keeping the layout backwards compatible. - Preparing installation of extensions in installation sets. - osl[in|de]crementInterlockedCount(): don't use "lock" prefix on single processor, single core, non HT machines. - Clean up obsolete files in binfilter. - Bug fixes.
16 lines
627 B
Text
16 lines
627 B
Text
$NetBSD: patch-bw,v 1.2 2007/04/05 23:24:01 hira Exp $
|
|
|
|
--- canvas/source/cairo/makefile.mk.orig 2007-02-02 03:59:18.000000000 +0900
|
|
+++ canvas/source/cairo/makefile.mk 2007-04-01 22:07:07.000000000 +0900
|
|
@@ -83,9 +83,9 @@
|
|
SHL1STDLIBS= $(CPPULIB) $(TKLIB) $(SALLIB) $(VCLLIB) $(COMPHELPERLIB) $(CPPUHELPERLIB) $(BASEGFXLIB) $(CANVASTOOLSLIB) $(TOOLSLIB)
|
|
|
|
.IF "$(SYSTEM_CAIRO)" == "YES"
|
|
-SHL1STDLIBS+= $(CAIRO_LIBS) -lX11 -lXrender
|
|
+SHL1STDLIBS+= $(CAIRO_LIBS) $(X11_LDFLAGS) -lX11 -lXrender
|
|
.ELSE
|
|
-SHL1STDLIBS+= -lcairo -lX11 -lXrender
|
|
+SHL1STDLIBS+= -lcairo $(X11_LDFLAGS) -lX11 -lXrender
|
|
.ENDIF
|
|
|
|
SHL1IMPLIB=i$(TARGET)
|