33016932fc
changes: * Security fixes: - Array Indexing Vulnerability in sdpplin_parse(). (CVE-2008-0073) - integer overflow, possibly leading to buffer overflow, CVE-2008-1482 * Reworked the plugin directory naming so that external plugins don't have to be rebuilt for every release * Made the version parsing much more reliable; it wasn't properly coping with four-part version numbers * Fixed an off-by-one in the FLAC security fix patch. This breakage was causing failure to play some files * Support 16-bit big-endian DTS audio * Improved frame snapshot API. (ABI extension.) * Re-add support for # (stream parameter separator) in raw filenames * Fixed long delay when closing stream on dual core systems pkgsrc note: CVE-2008-0073 was already fixed by patch
21 lines
839 B
Text
21 lines
839 B
Text
$NetBSD: patch-ao,v 1.15 2008/04/10 11:48:58 drochner Exp $
|
|
|
|
--- src/libw32dll/wine/Makefile.in.orig 2008-03-19 14:15:55.000000000 +0100
|
|
+++ src/libw32dll/wine/Makefile.in
|
|
@@ -58,7 +58,7 @@ mkinstalldirs = $(SHELL) $(top_srcdir)/m
|
|
CONFIG_HEADER = $(top_builddir)/include/configure.h
|
|
CONFIG_CLEAN_FILES =
|
|
LTLIBRARIES = $(noinst_LTLIBRARIES)
|
|
-libwine_la_LIBADD =
|
|
+libwine_la_LIBADD = ${WINE_LIBS}
|
|
am_libwine_la_OBJECTS = afl.lo driver.lo elfdll.lo ext.lo \
|
|
ldt_keeper.lo module.lo pe_image.lo pe_resource.lo resource.lo \
|
|
registry.lo vfl.lo win32.lo stubs.lo wrapper.lo
|
|
@@ -293,6 +293,7 @@ WAND_LIBS = @WAND_LIBS@
|
|
WAVPACK_CFLAGS = @WAVPACK_CFLAGS@
|
|
WAVPACK_LIBS = @WAVPACK_LIBS@
|
|
WIN32_CPPFLAGS = @WIN32_CPPFLAGS@
|
|
+WINE_LIBS = @WINE_LIBS@
|
|
XCBSHM_CFLAGS = @XCBSHM_CFLAGS@
|
|
XCBSHM_LIBS = @XCBSHM_LIBS@
|
|
XCBXV_CFLAGS = @XCBXV_CFLAGS@
|