pkgsrc/www/icedtea-web/patches/patch-Makefile.am
ryoon ab3854098f Update to 1.5.1
* Use devel/xulrunner31
* Sync with lang/openjdk7

Changelog:
New in release 1.5.1 (2014-08-13):
* Massively improved offline abilities.
* Improved to be able to run with any JDK
* JDK 8 support added (URLPermission granted if applicable)
* Added DE and PL localizations
* Added KEY_ENABLE_MANIFEST_ATTRIBUTES_CHECK deployment property to control scan of Manifest file
* Control Panel
  - Problem1856: ControlPanel UI improvement for lower resolutions (800*600)
* NetX
  - Problem1858: Java Console accepts multi-byte encodings
  - Problem1859: Java Console UI improvement for lower resolutions (800*600)
  - RH1091563: [abrt] icedtea-web-1.5-2.fc20: Uncaught exception java.lang.ClassCastException in method sun.applet.PluginAppletViewer$8.run()
* Plugin
  - Problem1743 - Intermittant deadlock in PluginRequestProcessor
  - RH1121549: coverity defects
* PolicyEditor
  - codebases without permissions assigned save to file anyway (and re-appear on next open)
  - Problem1776: NullPointer on save-and-exit
  - Custom permissions are properly formatted

New in release 1.5 (2014-04-02):
* IcedTea-Web now using tagsoup as default (tagsoup dependence) sanitizer for input
* JDK older then 1.5 no longer supported
* IcedTea-Web is now following XDG .config and .cache specification(RH947647)
* A console for debugging plugin and javaws
* Dialogs center on screen before becoming visible
* Support for u45 and u51 new manifest attributes (Application-Name, Codebase, Permissions, Trusted-only)
* Custom applet permission policies panel in itweb-settings control panel
* javaws -version flag
* New PolicyEditor for easily adding/removing permissions to individual applets
* Cache Viewer
  - Can be closed by ESC key
  - Enabling and disabling of operational buttons is handled properly
  - Time consuming operations are indicated by a mouse busy cursor
  - "Size" and "Last Modified" columns display localized data
* NetX
  - Problem1465 - java.io.FileNotFoundException while trying to download a JAR file
  - Netx can now parse malformed jnlp files using tagsoup
  - Problem1026 - Apps fail to run because of the nanoxml parser's strict XML validation
  - Problem1473 - javaws should not depend on name of local file
  - Redesigned About dialogue layout and contents
  - Console made aware of plugin messages
* Plugin
  - Problem854: Resizing an applet several times causes 100% CPU load
  - Problem1271: icedtea-web does not handle 'javascript:'-protocol URLs
  - RH976833: Multiple applets on one page cause deadlock
  - Pipes moved into XDG_RUNTIME_DIR
  - Added debug to file
  - RH1010958: insecure temporary file use flaw in LiveConnect implementation
* Common
  - Problem1474: Can't get javaws to use SOCKS proxy
  - Man page for itweb-settings
* Security Updates
  - CVE-2012-4540, RH869040: Heap-based buffer overflow after triggering event attached to applet
2014-11-03 12:31:01 +00:00

78 lines
3 KiB
Text

$NetBSD: patch-Makefile.am,v 1.3 2014/11/03 12:31:01 ryoon Exp $
* cp -a is not portable, DragonFly 3.2.2 has not -a option of cp at least.
* fix statement with "continue", should be '||' not '|' (pipe).
--- Makefile.am.orig 2014-08-14 10:15:46.945832128 +0000
+++ Makefile.am
@@ -250,9 +250,9 @@ if ENABLE_PLUGIN
endif
${INSTALL_DATA} $(NETX_DIR)/lib/classes.jar $(DESTDIR)$(datadir)/$(PACKAGE_NAME)/netx.jar
${INSTALL_DATA} $(NETX_SRCDIR)/javaws_splash.png $(DESTDIR)$(datadir)/$(PACKAGE_NAME)/javaws_splash.png
- ${INSTALL_PROGRAM} launcher.build/$(javaws) $(DESTDIR)$(bindir)
- ${INSTALL_PROGRAM} launcher.build/$(itweb_settings) $(DESTDIR)$(bindir)
- ${INSTALL_PROGRAM} launcher.build/$(policyeditor) $(DESTDIR)$(bindir)
+ ${INSTALL_SCRIPT} launcher.build/$(javaws) $(DESTDIR)$(bindir)
+ ${INSTALL_SCRIPT} launcher.build/$(itweb_settings) $(DESTDIR)$(bindir)
+ ${INSTALL_SCRIPT} launcher.build/$(policyeditor) $(DESTDIR)$(bindir)
install-data-local:
${mkinstalldirs} -d $(DESTDIR)$(mandir)/man1
@@ -262,15 +262,15 @@ install-data-local:
if ENABLE_DOCS
${mkinstalldirs} $(DESTDIR)$(htmldir)
(cd ${abs_top_builddir}/docs/netx; \
- for files in $$(find . -type f); \
+ for files in *; \
do \
- ${INSTALL_DATA} -D $${files} $(DESTDIR)$(htmldir)/netx/$${files}; \
+ ${INSTALL_DATA} $${files} $(DESTDIR)$(htmldir)/netx/; \
done)
if ENABLE_PLUGIN
(cd ${abs_top_builddir}/docs/plugin; \
- for files in $$(find . -type f); \
+ for files in *; \
do \
- ${INSTALL_DATA} -D $${files} $(DESTDIR)$(htmldir)/plugin/$${files}; \
+ ${INSTALL_DATA} $${files} $(DESTDIR)$(htmldir)/plugin/; \
done)
endif
endif
@@ -483,7 +483,7 @@ stamps/netx-html-gen.stamp:
touch $@
stamps/netx.stamp: netx-source-files.txt stamps/bootstrap-directory.stamp stamps/netx-html-gen.stamp
- mkdir -p $(NETX_DIR)
+ mkdir -p $(NETX_DIR)/net/sourceforge/jnlp/resources
$(BOOT_DIR)/bin/javac $(IT_JAVACFLAGS) \
-d $(NETX_DIR) \
-sourcepath $(NETX_SRCDIR) \
@@ -491,14 +491,14 @@ stamps/netx.stamp: netx-source-files.txt
$(NETX_CLASSPATH_ARG) \
@netx-source-files.txt
(cd $(NETX_RESOURCE_DIR); \
- for files in $$(find . -type f); \
+ for files in *; \
do \
- ${INSTALL_DATA} -D $${files} \
- $(NETX_DIR)/net/sourceforge/jnlp/resources/$${files}; \
+ ${INSTALL_DATA} $${files} \
+ $(NETX_DIR)/net/sourceforge/jnlp/resources/; \
done)
- cp -a $(NETX_SRCDIR)/net/sourceforge/jnlp/runtime/pac-funcs.js \
+ cp -RpP $(NETX_SRCDIR)/net/sourceforge/jnlp/runtime/pac-funcs.js \
$(NETX_DIR)/net/sourceforge/jnlp/runtime
- cp -a build.properties $(NETX_DIR)/net/sourceforge/jnlp/
+ cp -RpP build.properties $(NETX_DIR)/net/sourceforge/jnlp/
mkdir -p stamps
touch $@
@@ -1655,7 +1655,7 @@ stamps/bootstrap-directory.stamp: stamps
fi;
mkdir -p $(BOOT_DIR)/include && \
for i in $(SYSTEM_JDK_DIR)/include/*; do \
- test -r $$i | continue; \
+ test -r $$i || continue; \
i=`basename $$i`; \
rm -f $(BOOT_DIR)/include/$$i; \
ln -s $(SYSTEM_JDK_DIR)/include/$$i $(BOOT_DIR)/include/$$i; \