b2f04064f4
* New stars.dat format with HD catalog numbers and parallax errors omitted * Added catalog cross indexes for HD and SAO catalogs * Fixed bugs in parsing catalog numbers * Added white dwarf temperatures and spectral types DA, DB, DC, DO, DQ, and DZ * Added handling for partial spectral types where one or both of the subclass and luminosity class are unknown * Permit extended star attributes in .stc files: mesh, texture, rotation elements, semiaxes * Support multiple star systems of any complexity with orbits and barycenters * Changed .stc loader so that a star definition with a duplicate catalog number replaces the previous definition * Made catalog numbers optional in .stc files; stars can be defined without having to create fake catalog numbers * Star colors now chosen based on temperature; either 'classic' and black body colors may be selected * Bound % key to toggle between star color tables * Fixed black holes: infinite radius bug gone, rendered just as a plain black sphere * Added comprehensive catalog of all knows stars within 25 light years of the Sun, including orbits for multiple star systems [More] Changes 1.4.1 * Changed maximum number of eclipse shadows in OpenGL 2.0 path from two to three; if max is exceeded, clamp to three rather than not rendering the shadows at all. * Corrected a bad calculation in ring shadow shaders that caused ring shadows to be drawn in the wrong place. * Windows: Fixed the minimum feature size slider in the locations dialog so it updates in response to all the standard controls. * Added a correct InfoURL for the Moon * Windows: added splash screen with a progress indicator * Corrected a local flashing of the Milky Way brightness. * Now the distance to the galaxy center is displayed, if the observer is located inside the galaxy (Milky Way...). * Eliminated various incorrect Hubble type acronyms in deepsky.dsc that had penetrated the PERL filter. * Updated Titan and Iapetus textures in lores directory * Added lunar elevation map, using Clementine laser altimeter data, merged in the polar regions, with topographic data from Clementine 750 nm oblique and nadir images. * Updated/added Tethys textures in lores, medres and hires directories. * Added locations on Phoebe in satmoons2.ssc, as extracted from USGS/IAU official data. * Added Mesh for Phoebe texture. * Updated Iapetus texture. * Moved locations files from extras into data directory for inclusion in standard package. * Fixed bug where displayed time scale differed from actual time scale after clicking a cel URL. [More] Pkgsrc: * Use options.mk framework to build GLUT, GTK, GNOME, or KDE user interface.
13 lines
625 B
Text
13 lines
625 B
Text
$NetBSD: patch-aj,v 1.2 2006/02/17 23:46:40 adam Exp $
|
|
|
|
--- src/celestia/glutmain.cpp.orig 2005-07-19 22:30:59.000000000 +0200
|
|
+++ src/celestia/glutmain.cpp
|
|
@@ -521,7 +521,7 @@ int main(int argc, char* argv[])
|
|
// Set the simulation starting time to the current system time
|
|
time_t curtime=time(NULL);
|
|
appCore->start((double) curtime / 86400.0 + (double) astro::Date(1970, 1, 1));
|
|
- #ifdef MACOSX
|
|
+ #if defined(MACOSX) || defined(__DragonFly__)
|
|
/* localtime in Darwin is is reentrant only
|
|
equiv to Linux localtime_r()
|
|
should probably port !MACOSX code to use this too, available since
|