Update provided by Hasso Tepper on pkgsrc-users. Changes: 7.4.2: Bug fixes * Fixed segfault when rendering to front buffer with DRI 1. * Fixed swrast texture rectangle bug when wrap mode = GL_CLAMP_TO_BORDER and filter mode = GL_LINEAR. (bug 21461) * Fixed texture object mem leak during context destruction. * Fixed a state validation bug in glCopyTex[Sub]Image() * Fixed some i965 GLSL bugs. * Fixed an R300 driver texture object bad memory reference. 7.4.1: Bug fixes * Fixed a two-sided lighting bug in fixed-function-to-GPU code generation * Fixed some Darwin issues (Jeremy Huddleston) * Indexing the GLSL gl_EyePlane[] or gl_ObjectPlane[] arrays with a variable was broken, bug 20986 * Fixed incorrect texture unit bias in TXB instruction * glTexParameter settings weren't always propogated to drivers * Assorted vertex/fragment program bug fixes * Fixed point rendering in software rasterizer * Fixed potential deadlock in object hash functions * Fix a couple bugs surrounding front-buffer rendering with DRI2, but this is not quite complete. * Fixed glPopAttrib() bug when restoring user clip planes 7.4: New features * Added MESA_GLX_FORCE_DIRECT env var for Xlib/software driver * GLSL version 1.20 is returnd by the GL_SHADING_LANGUAGE_VERSION query Bug fixes * glGetActiveUniform() returned wrong size for some array types * Fixed some error checking in glUniform() * Fixed a potential glTexImage('proxy target') segfault * Fixed bad reference counting for 1D/2D texture arrays * Fixed VBO + glPush/PopClientAttrib() bug #19835 * Assorted i965 driver bug fixes * Fixed a Windows compilation failure in s_triangle.c * Fixed a GLSL array indexing bug * Fixes for building on Haiku Changes * Updated GL/glxext.h to version 48 * Assorted updates for building on Solaris 7.3: New features * Support for GLSL 1.20 * Intel DRI drivers now use GEM and DRI2 Bug fixes * Assorted GLSL bug fixes * Assorted i965 driver fixes * Fix for wglCreateLayerContext() in WGL/Windows driver * Build fixes for OpenBSD and gcc 2.95 * GLSL preprocessor handles #pragma now * Fix incorrect transformation of GL_SPOT_DIRECTION * Fixed several bugs (#18367 and #19625) in glXMakeContextCurrent() * Assorted Windows build fixes Changes * Deprecated the "XMesa" interface (include/GL/xmesa*.h files) * Deprecated the "FXMesa" interface (include/GL/fxmesa.h file) * Deprecated the "Allegro" interface (include/GL/amesa.h file) * Removed include/GL/uglmesa.h header * Removed include/GLView.h header for BeOS 7.2: New features * i965 driver: added support for G41 chipset (Intel) Bug fixes * Fixed display list bug involving primitives split across lists (bug 17564) * Fixed some issues with glBindAttribLocation() * Fixed crash in _tnl_InvalidateState() found with Amira (bug 15834) * Assorted bug fixes for Ming build * Fixed some vertex/pixel buffer object reference counting bugs * Fixed depth/stencil bug in i915/945 driver * Fixed some shader flow control bugs in i965 driver * Fixed a few tdfx driver bugs which prevented driver from working * Fixed multisample enable/disable bug Changes * Updated SGI header files with new license terms. 7.1: New features * autoconf-based configuration (and clean-up of Makefiles) * Assorted DRI driver enhancements * Reduced dependencies between X server and Mesa * GL_EXT_texture_from_pixmap extension for Xlib driver * Support for the GL shading language with i965 driver (implemented by Intel) * ATI R500 series support (Radeon X1300-X1950) in r300 DRI driver Bug fixes * Numerous GLSL fixes * Fixed some error code/detection bugs in the GLSL-related API functions * Lots of DRI driver fixes.
62 lines
2.1 KiB
Text
62 lines
2.1 KiB
Text
$NetBSD: patch-ai,v 1.3 2009/06/05 11:10:35 wiz Exp $
|
|
|
|
--- ./src/mesa/drivers/dri/Makefile.template.orig 2009-03-13 05:28:49 +0200
|
|
+++ ./src/mesa/drivers/dri/Makefile.template 2009-05-17 15:52:13 +0300
|
|
@@ -1,6 +1,6 @@
|
|
# -*-makefile-*-
|
|
|
|
-MESA_MODULES = $(TOP)/src/mesa/libmesa.a
|
|
+MESA_MODULES = $(TOP)/src/mesa/libmesa.la
|
|
|
|
COMMON_SOURCES = \
|
|
../common/utils.c \
|
|
@@ -48,25 +48,22 @@ SHARED_INCLUDES = \
|
|
##### RULES #####
|
|
|
|
.c.o:
|
|
- $(CC) -c $(INCLUDES) $(CFLAGS) $(DRIVER_DEFINES) $< -o $@
|
|
+ $(LIBTOOL) --mode=compile --tag=CC $(CC) -c -prefer-pic \
|
|
+ $(INCLUDES) $(CFLAGS) $(DRIVER_DEFINES) $< -o $(@:.o=.lo)
|
|
|
|
.S.o:
|
|
- $(CC) -c $(INCLUDES) $(CFLAGS) $(DRIVER_DEFINES) $< -o $@
|
|
+ $(LIBTOOL) --mode=compile --tag=CC $(CC) -c -prefer-pic \
|
|
+ $(INCLUDES) $(CFLAGS) $(DRIVER_DEFINES) $< -o $(@:.o=.lo)
|
|
|
|
|
|
##### TARGETS #####
|
|
|
|
-default: symlinks depend $(LIBNAME) $(TOP)/$(LIB_DIR)/$(LIBNAME)
|
|
-
|
|
-
|
|
-$(LIBNAME): $(OBJECTS) $(MESA_MODULES) $(WINOBJ) Makefile $(TOP)/src/mesa/drivers/dri/Makefile.template
|
|
- $(MKLIB) -o $@ -noprefix -linker '$(CC)' -ldflags '$(LDFLAGS)' \
|
|
- $(OBJECTS) $(MESA_MODULES) $(WINOBJ) $(DRI_LIB_DEPS)
|
|
-
|
|
-
|
|
-$(TOP)/$(LIB_DIR)/$(LIBNAME): $(LIBNAME)
|
|
- $(INSTALL) $(LIBNAME) $(TOP)/$(LIB_DIR)
|
|
+default: symlinks depend $(TOP)/$(LIB_DIR)/$(LIBNAME)
|
|
|
|
+$(TOP)/$(LIB_DIR)/$(LIBNAME): $(OBJECTS) $(MESA_MODULES) $(WINOBJ) Makefile $(TOP)/src/mesa/drivers/dri/Makefile.template
|
|
+ $(LIBTOOL) --mode=link $(CC) -o $(TOP)/$(LIB_DIR)/$(LIBNAME:.so=.la) \
|
|
+ $(OBJECTS:.o=.lo) $(WINOBJ:.o=.lo) $(DRI_LIB_DEPS) \
|
|
+ $(MESA_MODULES:.a=.la) -rpath $(PREFIX)/lib -module -avoid-version
|
|
|
|
depend: $(C_SOURCES) $(ASM_SOURCES) $(SYMLINKS)
|
|
touch depend
|
|
@@ -85,9 +82,11 @@ clean:
|
|
-rm -f depend depend.bak
|
|
|
|
|
|
-install: $(LIBNAME)
|
|
- $(INSTALL) -d $(DESTDIR)$(DRI_DRIVER_INSTALL_DIR)
|
|
- $(INSTALL) -m 755 $(LIBNAME) $(DESTDIR)$(DRI_DRIVER_INSTALL_DIR)
|
|
+install: $(TOP)/$(LIB_DIR)/$(LIBNAME)
|
|
+ $(BSD_INSTALL_LIB_DIR) $(DESTDIR)$(DRI_DRIVER_INSTALL_DIR)
|
|
+ $(LIBTOOL) --mode=install \
|
|
+ $(BSD_INSTALL_LIB) $(TOP)/$(LIB_DIR)/$(LIBNAME:.so=.la) \
|
|
+ $(DESTDIR)$(DRI_DRIVER_INSTALL_DIR)
|
|
|
|
|
|
-include depend
|