121 lines
3.8 KiB
Text
121 lines
3.8 KiB
Text
--- configure.in.orig Thu Dec 14 11:49:06 2000
|
|
+++ configure.in Tue Aug 28 17:09:57 2001
|
|
@@ -213,7 +213,12 @@
|
|
getlogin getpass fcntl readdir sysinfo ioctl chdir tempnam \
|
|
getsockopt setsockopt \
|
|
gettimeofday mktime timegm tzset)
|
|
-AC_CHECK_FUNC(unlink, , AC_CHECK_FUNC(remove, AC_DEFINE(unlink, remove)))
|
|
+AC_CHECK_FUNC(unlink)
|
|
+if test "$ac_cv_func_unlink" != yes; then
|
|
+ AC_CHECK_FUNC(remove)
|
|
+fi
|
|
+
|
|
+dnl AC_CHECK_FUNC(unlink, , AC_CHECK_FUNC(remove, AC_DEFINE(unlink, remove)))
|
|
|
|
dnl Checks for configuration arguments
|
|
AC_MSG_CHECKING(whether to support direct WAIS access.)
|
|
@@ -307,7 +312,10 @@
|
|
AC_MSG_RESULT(yes)
|
|
AC_DEFINE(HT_POSIX_REGEX)
|
|
if test "x$withval" = "xyes"; then
|
|
- AC_CHECK_LIB(rx, regexec, [ LIBS="-lrx $LIBS" ] )
|
|
+ AC_TRY_LINK([],
|
|
+ [ regexec(); ],
|
|
+ [],
|
|
+ [ AC_CHECK_LIB(rx, regexec, [ LIBS="-lrx $LIBS" ] ) ] )
|
|
else
|
|
AC_ADDLIB($withval)
|
|
AC_TRY_LINK([],
|
|
@@ -532,31 +540,9 @@
|
|
AC_SUBST(LWWWMD5)
|
|
AC_SUBST(LIBWWWMD5)
|
|
|
|
-dnl Checks for libwww and OpenSSL:
|
|
-AC_MSG_CHECKING(whether we can find OpenSSL)
|
|
-dnl find the ssl library dir (empirical)
|
|
-if test -d '/usr/local/ssl/lib'; then
|
|
- ssllib="-L/usr/local/ssl/lib -lssl -lcrypto"
|
|
-else
|
|
- ssllib="-L/usr/lib -lssl -lcrypto"
|
|
-fi
|
|
-dnl find the ssl include dir (empirical)
|
|
-if test -d '/usr/local/ssl/include'; then
|
|
- sslinc="-I/usr/local/ssl/include"
|
|
-elif test -d '/usr/local/openssl/include'; then
|
|
- sslinc="-I/usr/local/openssl/include"
|
|
-elif test -d '/usr/local/include/openssl'; then
|
|
- sslinc="-I/usr/local/include/openssl"
|
|
-elif test -d '/usr/include/ssl'; then
|
|
- sslinc="-I/usr/include/ssl"
|
|
-elif test -d '/usr/include/openssl'; then
|
|
- sslinc="-I/usr/include/openssl"
|
|
-else
|
|
- sslinc=""
|
|
-fi
|
|
+dnl Checks for OpenSSL:
|
|
+AC_MSG_CHECKING(whether to support OpenSSL.)
|
|
WWWSSL=""
|
|
-SSLINC=""
|
|
-LIBSSL=""
|
|
LWWWSSL=""
|
|
LIBWWWSSL=""
|
|
WWWSSLEX=""
|
|
@@ -568,14 +554,39 @@
|
|
;;
|
|
*)
|
|
if test "x$withval" = "xyes"; then
|
|
- withval=$ssllib
|
|
- SSLINC=$sslinc
|
|
+ dnl find the ssl library dir (empirical)
|
|
+ if test -d '/usr/local/ssl/lib'; then
|
|
+ ssllib="-L/usr/local/ssl/lib -lssl -lcrypto"
|
|
+ else
|
|
+ ssllib="-L/usr/lib -lssl -lcrypto"
|
|
+ fi
|
|
+ dnl find the ssl include dir (empirical)
|
|
+ if test -d '/usr/local/ssl/include'; then
|
|
+ sslinc="-I/usr/local/ssl/include"
|
|
+ elif test -d '/usr/local/openssl/include'; then
|
|
+ sslinc="-I/usr/local/openssl/include"
|
|
+ elif test -d '/usr/local/include/openssl'; then
|
|
+ sslinc="-I/usr/local/include/openssl"
|
|
+ elif test -d '/usr/include/ssl'; then
|
|
+ sslinc="-I/usr/include/ssl"
|
|
+ elif test -d '/usr/include/openssl'; then
|
|
+ sslinc="-I/usr/include/openssl"
|
|
+ else
|
|
+ sslinc=""
|
|
+ fi
|
|
+ SSLINC="$sslinc"
|
|
+ SSLLIBS="$ssllib"
|
|
+ else
|
|
+ SSLINC="-I${withval}/include -I${withval}/include/openssl"
|
|
+ SSLLIBS="-L${withval}/lib -lssl -lcrypto"
|
|
fi
|
|
- LIBS="$LIBS $withval"
|
|
+ SAVED_LIBS="${LIBS}"
|
|
+ LIBS="${SSLLIBS}"
|
|
AC_TRY_LINK([],
|
|
[ SSL_library_init(); ],
|
|
[],
|
|
[ AC_MSG_ERROR(Could not find the $withval libraries. You must first install openSSL.) ])
|
|
+ LIBS="${SAVED_LIBS}"
|
|
AC_MSG_RESULT(yes)
|
|
WWWSSL="libwwwssl.la"
|
|
LWWWSSL="-lwwwssl"
|
|
@@ -586,6 +597,7 @@
|
|
[ AC_MSG_RESULT(no) ])
|
|
AC_SUBST(WWWSSL)
|
|
AC_SUBST(SSLINC)
|
|
+AC_SUBST(SSLLIBS)
|
|
AC_SUBST(LWWWSSL)
|
|
AC_SUBST(LIBWWWSSL)
|
|
AC_SUBST(WWWSSLEX)
|
|
@@ -1006,7 +1018,6 @@
|
|
Library/Makefile Library/User/Makefile Library/User/Patch/Makefile
|
|
Library/User/Architecture/Makefile Library/User/Using/Makefile Library/User/Guide/Makefile
|
|
Library/User/Style/Makefile Library/User/Platform/Makefile
|
|
-Library/Test/Makefile Library/Test/User/Makefile Library/Test/src/Makefile
|
|
Library/src/Makefile Library/src/windows/Makefile Library/src/vms/Makefile
|
|
Library/src/SSL/Makefile Library/src/SSL/windows/Makefile
|
|
Library/Examples/Makefile
|