pkgsrc/games/wesnoth/patches/patch-CMakeLists.txt
adam 125d87d2de Changes 1.10.3:
* Campaigns:
   * Heir to the Throne:
     * Fixed bug 19531: scroll to reinforcement units in Blackwater Port
     * Fixed bug 19517: The injured sergeant in HttT: Cliffs of Thoria will now
       always become visible when he is discovered.
   * Under the Burning Suns:
     * Made it so that all units are rehydrated quietly upon victory in scenario
       two
   * Under the Burning Suns:
     * Fix bug 19630: unit lost when Nym returns
     * Dust Devil no longer comments on cuttlefish
     * Wolf Riders now utter fleeing message on easy in scenario 3
 * Editor:
   * Improved performance of the Editor Settings ToD lighting controls
 * Language and i18n:
   * Fixed untranslatable Cancel button label in the add-ons server network
     status dialog (bug 19659)
   * Updated translations: Chinese (Simplified), Finnish, French, Galician,
     Irish, Italian, Korean, Latin, Old English, Portuguese (Brazil), Russian
 * Multiplayer:
   * A New Land:
     * Made it so that the "Elvish Shaman" option in the elvish unit selection
       menu gets translated. Fixes bug 19677.
 * User interface:
   * Stop showing a unit's potential moves before moving in a move & attack,
     rather than after (more consistent with regular movement)
 * Whiteboard:
   * Fixed bug 19613: Multiple attacks after planning attacks in whiteboard
   * Fixed bug 19619: In local games, units keep ghosted appearance during
     opponent's turn
   * Fixed bug 19618: Problems with ending turn with impossible moves
   * Fixed bug 19615: Can see part of opponents' planned moves in local
     multiplayer game
 * WML engine:
   * Fix $owner_side in capture events fired due to unit movement
 * Miscellaneous and bug fixes:
   * Fixed: A preprocessor bug looking beyond the end of a buffer.
   * Fixed: Binding a temporary in the network code, possibly causing
     crashing.
   * Fixed bug 19469: Missing scenario hash results in Remote scenario always
     added to game description
   * Fixed bug 19322: controller=null hides a side in the status table
   * Fixed bug 19681: cache is never valid tweaked the number to string
     conversion of config_attribute
   * Fixed bug 16544: Fail to read `empty' cache files.
   * Added shroud_data to the inspection window (FR 19623).
   * Fixed: Wrong current side number after side turns (bug 19735)
     It also affected the lua field wesnoth.current.side
2012-07-18 06:37:40 +00:00

38 lines
1.6 KiB
Text

$NetBSD: patch-CMakeLists.txt,v 1.1 2012/07/18 06:37:41 adam Exp $
Don't look for X11 on Mac OS X
Fix MANDIR
--- CMakeLists.txt.orig 2012-05-01 21:08:26.000000000 +0000
+++ CMakeLists.txt
@@ -27,7 +27,9 @@ find_package(Gettext)
# src/gettext.cpp since it includes libintl.h)
find_package(Libintl REQUIRED)
+if(NOT APPLE)
find_package(X11)
+endif(NOT APPLE)
if(NOT MSVC)
#needed to get some SDL defines in... (as of rev31694 -D_GNU_SOURCE=1 is required!)
@@ -55,7 +57,7 @@ include(SearchForStuff)
set(BINDIR "bin" CACHE STRING "Where to install binaries")
set(DATAROOTDIR "${CMAKE_INSTALL_PREFIX}/share" CACHE STRING "Sets the root of data directories to a non-default location")
set(DOCDIR "${DATAROOTDIR}/doc/wesnoth" CACHE STRING "Sets the doc directory to a non-default location.")
-set(MANDIR "${DATAROOTDIR}/man" CACHE STRING "Where to install manpages")
+set(MANDIR "man" CACHE STRING "Where to install manpages")
set(DATADIRNAME "wesnoth" CACHE STRING "change the name of the directory for the read-only architecture-independent game data")
set(EXECUTABLE_OUTPUT_PATH "${CMAKE_BINARY_DIR}" CACHE STRING "change the dir where binaries are placed right at compile time")
set(LOCALEDIR "translations" CACHE STRING "change the name of the locale data directory to a non-default name")
@@ -307,11 +309,6 @@ install(FILES l10n-track DESTINATION ${D
# uninstall
#
-configure_file(
- "${CMAKE_MODULE_PATH}/uninstall.cmake.in"
- "${CMAKE_CURRENT_BINARY_DIR}/uninstall.cmake"
- IMMEDIATE @ONLY
-)
add_custom_target(uninstall
"${CMAKE_COMMAND}" -P "${CMAKE_CURRENT_BINARY_DIR}/uninstall.cmake"