34caa69847
- drop two patches, upstream corrected. (the comments on patches were): The key argument of std::map must not be const as it can't be assigned internally otherwise. - Add buildlink to audio/libvorbis, sysutils/dbus - Add sysutils/desktop-file-utils/desktopdb.mk to include - Add post-patch: target to removed patched *.orig files (otherwise those are installed) - Adjust several REPLACE_PYTHON and REPLACE_BASH - Add patch to correct missing shebang lines necessary for REPLACE_.* Update 1.10.7 to 1.12.1 ----------------------- - changelog is too huge to list here, instead pick only for 1.12.1 from: http://www.wesnoth.org/ Wesnoth 1.12.1 Sunday, January 25 2015 Wesnoth 1.12.1 is now available. This is a maintenance release for the stable 1.12.x series and, as such, it delivers an assortment of bug fixes and other improvements over version 1.12.0. Check the forum thread for a list of the most notable changes in this version. As on previous occasions, we also offer two versions of the changelog: a trimmed-down players changelog including only those items considered to be relevant in regular gameplay, and a more technical full changelog for enthusiasts and content creators. The source code, Windows, and Apple OS X packages are already available on the downloads page. You may also find packages for other platforms there as they become available. You may comment on this release in the forums.
11 lines
487 B
Text
11 lines
487 B
Text
$NetBSD: patch-data_tools_wesnoth_campaignserver__client_py,v 1.1 2015/03/10 05:16:28 mef Exp $
|
|
|
|
Add shebang (to match REPLACE.python.old= .*python[^ ]*)
|
|
|
|
--- data/tools/wesnoth/campaignserver_client.py~ 2015-03-10 10:48:54.000000000 +0900
|
|
+++ data/tools/wesnoth/campaignserver_client.py 2015-03-10 11:15:44.000000000 +0900
|
|
@@ -1,3 +1,4 @@
|
|
+#!@/python@
|
|
import gzip, zlib, StringIO
|
|
import socket, struct, glob, sys, shutil, threading, os, fnmatch
|
|
import wesnoth.wmldata as wmldata
|