9c709e4278
* Date: & Message-Id: revert to normally being appended to a message, only prepend for the Resent-* case. Fixes regression introduced in Exim 4.70 by NM/22 for Bugzilla 607. * Include check_rfc2047_length in configure.default because we're seeing increasing numbers of administrators be bitten by this. * Added DISABLE_DKIM and comment to src/EDITME * Bugzilla 994: added openssl_options main configuration option. * Bugzilla 995: provide better SSL diagnostics on failed reads. * Bugzilla 834: provide a permit_coredump option for pipe transports. * Adjust NTLM authentication to handle SASL Initial Response. * If TLS negotiated an anonymous cipher, we could end up with SSL but without a peer certificate, leading to a segfault because of an assumption that peers always have certificates. Be a little more paranoid. * Bugzilla 926: switch ClamAV to use the new zINSTREAM API for content filtering; old API available if built with WITH_OLD_CLAMAV_STREAM=yes NB: ClamAV planning to remove STREAM in "middle of 2010". CL also introduces -bmalware, various -d+acl logging additions and more caution in buffer sizes. * Implemented reverse_ip expansion operator. * Bugzilla 937: provide a "debug" ACL control. * Bugzilla 922: Documentation dusting, patch provided by John Horne. * Bugzilla 973: Implement --version. * Bugzilla 752: Refuse to build/run if Exim user is root/0. * Build without WITH_CONTENT_SCAN. Path from Andreas Metzler. * Bugzilla 816: support multiple condition rules on Routers. * Add bool_lax{} expansion operator and use that for combining multiple condition rules, instead of bool{}. Make both bool{} and bool_lax{} ignore trailing whitespace. * prevent non-panic DKIM error from being sent to paniclog * added tcp_wrappers_daemon_name to allow host entries other than "exim" to be used * Fix malware regression for cmdline scanner introduced in PP/08. Notification from Dr Andrew Aitchison. * Change ClamAV response parsing to be more robust and to handle ClamAV's ExtendedDetectionInfo response format. * OpenSSL 1.0.0a compatibility const-ness change, should be backwards compatible.
123 lines
4 KiB
Text
123 lines
4 KiB
Text
$NetBSD: patch-aa,v 1.21 2011/01/12 07:52:44 adam Exp $
|
|
|
|
--- Local/Makefile.pkgsrc.orig 2011-01-12 07:35:17.000000000 +0000
|
|
+++ Local/Makefile.pkgsrc
|
|
@@ -100,7 +100,7 @@
|
|
# /usr/local/sbin. The installation script will try to create this directory,
|
|
# and any superior directories, if they do not exist.
|
|
|
|
-BIN_DIRECTORY=/usr/exim/bin
|
|
+BIN_DIRECTORY=@PREFIX@/sbin
|
|
|
|
|
|
#------------------------------------------------------------------------------
|
|
@@ -116,7 +116,7 @@ BIN_DIRECTORY=/usr/exim/bin
|
|
# don't exist. It will also install a default runtime configuration if this
|
|
# file does not exist.
|
|
|
|
-CONFIGURE_FILE=/usr/exim/configure
|
|
+CONFIGURE_FILE=@PKG_SYSCONFDIR@/configure
|
|
|
|
# It is possible to specify a colon-separated list of files for CONFIGURE_FILE.
|
|
# In this case, Exim will use the first of them that exists when it is run.
|
|
@@ -133,7 +133,7 @@ CONFIGURE_FILE=/usr/exim/configure
|
|
# deliveries. (Local deliveries run as various non-root users, typically as the
|
|
# owner of a local mailbox.) Specifying these values as root is not supported.
|
|
|
|
-EXIM_USER=
|
|
+EXIM_USER=ref:@EXIM_USER@
|
|
|
|
# If you specify EXIM_USER as a name, this is looked up at build time, and the
|
|
# uid number is built into the binary. However, you can specify that this
|
|
@@ -154,7 +154,7 @@ EXIM_USER=
|
|
# for EXIM_USER (e.g. EXIM_USER=exim), you don't need to set EXIM_GROUP unless
|
|
# you want to use a group other than the default group for the given user.
|
|
|
|
-# EXIM_GROUP=
|
|
+EXIM_GROUP=ref:@EXIM_GROUP@
|
|
|
|
# Many sites define a user called "exim", with an appropriate default group,
|
|
# and use
|
|
@@ -175,7 +175,7 @@ EXIM_USER=
|
|
|
|
# Almost all installations choose this:
|
|
|
|
-SPOOL_DIRECTORY=/var/spool/exim
|
|
+SPOOL_DIRECTORY=@VARBASE@/spool/exim
|
|
|
|
|
|
|
|
@@ -332,7 +332,7 @@ PCRE_LIBS=-lpcre
|
|
# files are defaulted in the OS/Makefile-Default file, but can be overridden in
|
|
# local OS-specific make files.
|
|
|
|
-EXIM_MONITOR=eximon.bin
|
|
+# EXIM_MONITOR=eximon.bin
|
|
|
|
|
|
#------------------------------------------------------------------------------
|
|
@@ -527,11 +527,11 @@ FIXED_NEVER_USERS=root
|
|
# included in the Exim binary. You will then need to set up the run time
|
|
# configuration to make use of the mechanism(s) selected.
|
|
|
|
-# AUTH_CRAM_MD5=yes
|
|
+AUTH_CRAM_MD5=yes
|
|
# AUTH_CYRUS_SASL=yes
|
|
# AUTH_DOVECOT=yes
|
|
-# AUTH_PLAINTEXT=yes
|
|
-# AUTH_SPA=yes
|
|
+AUTH_PLAINTEXT=yes
|
|
+AUTH_SPA=yes
|
|
|
|
|
|
#------------------------------------------------------------------------------
|
|
@@ -697,7 +697,7 @@ HEADERS_CHARSET="ISO-8859-1"
|
|
# %s. This will be replaced by one of the strings "main", "panic", or "reject"
|
|
# to form the final file names. Some installations may want something like this:
|
|
|
|
-# LOG_FILE_PATH=/var/log/exim_%slog
|
|
+LOG_FILE_PATH=@VARBASE@/log/exim/%s
|
|
|
|
# which results in files with names /var/log/exim_mainlog, etc. The directory
|
|
# in which the log files are placed must exist; Exim does not try to create
|
|
@@ -945,13 +945,13 @@ SYSTEM_ALIASES_FILE=/etc/aliases
|
|
# haven't got Perl, Exim will still build and run; you just won't be able to
|
|
# use those utilities.
|
|
|
|
-# CHOWN_COMMAND=/usr/bin/chown
|
|
-# CHGRP_COMMAND=/usr/bin/chgrp
|
|
-# CHMOD_COMMAND=/usr/bin/chmod
|
|
-# MV_COMMAND=/bin/mv
|
|
-# RM_COMMAND=/bin/rm
|
|
-# TOUCH_COMMAND=/usr/bin/touch
|
|
-# PERL_COMMAND=/usr/bin/perl
|
|
+CHOWN_COMMAND=@CHOWN@
|
|
+CHGRP_COMMAND=@CHGRP@
|
|
+CHMOD_COMMAND=@CHMOD@
|
|
+MV_COMMAND=@MV@
|
|
+RM_COMMAND=@RM@
|
|
+TOUCH_COMMAND=@TOUCH@
|
|
+PERL_COMMAND=@PERL5@
|
|
|
|
|
|
#------------------------------------------------------------------------------
|
|
@@ -1145,7 +1145,7 @@ TMPDIR="/tmp"
|
|
# (process id) to a file so that it can easily be identified. The path of the
|
|
# file can be specified here. Some installations may want something like this:
|
|
|
|
-# PID_FILE_PATH=/var/lock/exim.pid
|
|
+PID_FILE_PATH=/var/run/exim.pid
|
|
|
|
# If PID_FILE_PATH is not defined, Exim writes a file in its spool directory
|
|
# using the name "exim-daemon.pid".
|
|
@@ -1197,3 +1197,10 @@ TMPDIR="/tmp"
|
|
# ENABLE_DISABLE_FSYNC=yes
|
|
|
|
# End of EDITME for Exim 4.
|
|
+
|
|
+EXTRALIBS_EXIM=-liconv
|
|
+
|
|
+@EXIM_USE_DB_CONFIG@
|
|
+@EXIM_DBMLIB@
|
|
+INCLUDE=@EXIM_INCLUDE@
|
|
+LOOKUP_LIBS=@LOOKUP_LIBS@
|