163cf8010a
Version 2.5 * fixed lang.map for php files * fixed url.lang * --debug-langdef can be interactive * nohilite.lang that does not perform any highlighting, but only formats the input file into the output format (dealing with output format special characters) * default.lang to which source-highlight falls back when no input language is specified or available * infer script languages * --header and --footer options do not require --doc option * --statistics print elapsed time * highlight cls, dtx and sty LaTeX files * language definition for Tcl * language definition for Sql * language definition for bibtex * infer language of script files Version 2.4 * language definition for C# (thanks to Hemmi Shigeru) * language definition for XML (thanks to Andy Buckley) * language definition for shell scripts (thanks to Dirk Jagdmann) * fixed language definition for HTML (tags with numbers are highlighted, e.g., <h1>) * updated language definition for logtalk (thanks to Paulo Moura) * produces the list of elements of a language definition file (--show-lang-elements) * output format definition for HTML where fonts by default are not fixed width. * bug fix in url regular expressions * bug fix with nonsensitive keywords (thanks to Andrea Ercolino) * improved documentation concerning installation of Boost regex library Version 2.3 * the regex automaton is printed on the standard output (instead of the standard error) * language definition for postscript * DocBook output format * fixed bug in .map files with \r characters * fixed expression for email Version 2.2 * fixed a bug that sigsegv when more than one input file is provided * fixed a compilation error with gcc 4.0 * generate references using ctags * fixed a bug with LaTeX output of " with some inputencs and with latexcolor * handle direct color specifications independently from HTML * fixed conversion of hexadecimal characters in output language definitions * fixed compilation error with regex 1.33 * include man page * language definition for diff output * fixed bugs in generation of the regular expression automaton * extended documentation with some tutorials on input language definitions * generate more compact output (reduced size) * in LaTeX output longtable is not used anymore
13 lines
590 B
Text
13 lines
590 B
Text
$NetBSD: patch-ab,v 1.4 2007/02/22 20:35:35 wiz Exp $
|
|
|
|
--- src/lib/Makefile.in.orig 2006-10-05 16:57:30.000000000 +0000
|
|
+++ src/lib/Makefile.in
|
|
@@ -845,7 +845,7 @@ optparser.cc optparser.h: $(srcdir)/optp
|
|
$(YACC) -p opsc_ -o $@ $(srcdir)/optparser.yy --defines=$*.h
|
|
|
|
mytags: $(srcdir)/test_readtags_main.cpp
|
|
- ctags --excmd=n --fields=+n -o mytags $(srcdir)/test_readtags_main.cpp $(srcdir)/readtags.h
|
|
+ $(CTAGS) --excmd=n --fields=+n -o mytags $(srcdir)/test_readtags_main.cpp $(srcdir)/readtags.h
|
|
|
|
outlangtest.outlang: $(srcdir)/outlangtest.outlang.tmpl
|
|
rm -f outlangtest.outlang
|