2fa964e67e
Changes: Fixes for small problem with List widget. More work required on this ... Fixes for some recently introduced bugs within configure. Now link libXm* against -lm if ANSI C math stuff is hidden there Small Scale widget fix (rounding problem) Added two stubs for missing 2.x interfaces. On stub level we should be very close to a complete 2.1 set now Fixes by Kazuyuki Funada, mostly for i18n. Fix and add more (incomplete) man pages to the install target Link our shared libraries against the necessary system libraries (e.g. libXt, libX11) to hardcode the dependencies Rename libDt to libDtPrint, this appears to be what it's called. Remove the print_screen field from struct DtPrintSetupData, the Motif 2.1 manual pages (e.g. about XmPrintSetup) are misleading about libDtPrint. Add -lMrm to the Xlt tests, this is necessary as SciPlot now uses Mrm. Make build option --with-dmalloc to work again properly Make more debugging functions available in a PRODUCTION build (no performance penalty) Debugging output (DEBUG_FILE env var) is now always explicitly unbuffered and can now be sent to "stdin"/"stderr" as well The environment variable controlling which files send debugging output has been renamed to DEBUG_SOURCES and now accepts a blocking entries Debugging output can now be en-/disabled upon runtime. (env vars DEBUG_TOGGLE, DEBUG_SIGNAL)
57 lines
1.7 KiB
Text
57 lines
1.7 KiB
Text
$NetBSD: patch-aa,v 1.17 2001/03/28 14:57:55 drochner Exp $
|
|
|
|
--- Makefile.am.orig Fri Dec 22 13:25:49 2000
|
|
+++ Makefile.am Wed Mar 28 13:44:48 2001
|
|
@@ -3,25 +3,32 @@
|
|
#
|
|
|
|
MAINTAINERCLEANFILES=Makefile.in configure libtool config.guess config.sub ltconfig ltmain.sh aclocal.m4 config.h.in install-sh missing mkinstalldirs release-notes.html release-notes.txt
|
|
+if Version_1_2
|
|
+SUBDIRS = include lib
|
|
+else
|
|
SUBDIRS = include scripts lib clients doc @BuildTestDir@
|
|
+endif
|
|
|
|
DIST_SUBDIRS = include scripts lib clients doc test
|
|
|
|
AUTOMAKE_OPTIONS = 1.4
|
|
|
|
+EXTRA_DIST= acconfig.h configure \
|
|
+ BUG-REPORTING CREDITS KNOWN_BUGS RELEASE-POLICY NOTES
|
|
+
|
|
#
|
|
# Install some information files
|
|
#
|
|
# Lets put the informational stuff in a sub directory to avoid
|
|
# poluting /usr/local for default installs.
|
|
#
|
|
-rootdir= $(exec_prefix)/LessTif
|
|
+# Only install the documentation if installing 2.0-compatible libraries.
|
|
+#
|
|
+if Version_2_0
|
|
+rootdir= $(docdir)
|
|
root_DATA= AUTHORS BUG-REPORTING COPYING COPYING.LIB CREDITS \
|
|
KNOWN_BUGS README RELEASE-POLICY release-notes.txt
|
|
|
|
-EXTRA_DIST= acconfig.h configure \
|
|
- BUG-REPORTING CREDITS KNOWN_BUGS RELEASE-POLICY NOTES
|
|
-
|
|
@MAINT@changelog:
|
|
@MAINT@ @ cvs -Q -z9 log -rrelease_@MAJOR_VERSION@_@MINOR_VERSION@_@PICO_VERSION@: \
|
|
@MAINT@ acconfig.h acinclude.m4 configure.in Makefile.am \
|
|
@@ -34,7 +41,6 @@
|
|
@MAINT@ doc/lessdox \
|
|
@MAINT@ | $(srcdir)/scripts/parselog >ChangeLog
|
|
|
|
-htmldir= $(exec_prefix)/LessTif/doc
|
|
html_DATA= release-notes.html
|
|
|
|
all-local: BUG-REPORTING
|
|
@@ -51,6 +57,7 @@
|
|
|
|
#install-data-hook:
|
|
# ${INSTALL_DATA} $(srcdir)/NOTES $(DESTDIR)$(htmldir)/release-notes.html
|
|
+endif
|
|
|
|
|
|
#
|