since I'm most familiar with the hack to include the LessTif X11 config files. Relevant changes from version 0.91.8: * Build/Install Uil libs and Headers (and tests) by default. * Fixed some FontList interfaces to conform to the docs. Might fix memory leaks as well. * Ongoing work to use ANSI C89 as much as possible. Drop alternatives being used (e.g. bcopy() and friends) * The Motif 2.x Xme() funcs should now all exist in stubs at least; some had already been "implemented" earlier. * Build support for a Motif 2.1 compatible tree. This will soon replace the 2.0 tree. * Work in progres for creating XmPrint API. (2.1 functionality)
29 lines
658 B
Text
29 lines
658 B
Text
$NetBSD: patch-aj,v 1.11 2000/12/22 17:26:19 jlam Exp $
|
|
|
|
--- clients/Motif-2.1/uil/Makefile.am.orig Thu Dec 7 04:12:29 2000
|
|
+++ clients/Motif-2.1/uil/Makefile.am
|
|
@@ -5,8 +5,12 @@
|
|
if Version_2_1
|
|
bin_PROGRAMS= uil
|
|
noinst_PROGRAMS = newuil
|
|
-endif
|
|
+if DefaultVersion21
|
|
+bindir = $(prefix)/bin
|
|
+else
|
|
bindir = $(prefix)/LessTif/Motif2.1/bin
|
|
+endif
|
|
+endif
|
|
|
|
MAINTAINERCLEANFILES=Makefile.in lex.c yacc.c yacc.h
|
|
|
|
@@ -75,10 +79,3 @@
|
|
rm $$i; \
|
|
fi ; \
|
|
done
|
|
-
|
|
-install-data-hook:
|
|
-if DefaultVersion21
|
|
- -rm -f $(DESTDIR)$(prefix)/bin/$(bin_PROGRAMS)
|
|
- (cd $(DESTDIR)$(prefix)/bin && $(LN_S) ../LessTif/Motif2.1/bin/$(bin_PROGRAMS) .)
|
|
-endif
|
|
-
|