pkgsrc/databases/postgresql95/patches/patch-src_backend_Makefile
tnn 76b3088729 Add postgresql95 packages, converted from corresponding postgresql94
packages. postgresql95-upgrade is gone, the pg_upgrade tool is shipped
with postgresql95-client now.

Major enhancements in PostgreSQL 9.5 include:

  Allow INSERTs that would generate constraint conflicts to be turned into
    UPDATEs or ignored
  Add GROUP BY analysis features GROUPING SETS, CUBE and ROLLUP
  Add row-level security control
  Create mechanisms for tracking the progress of replication, including
    methods for identifying the origin of individual changes during logical
    replication
  Add Block Range Indexes (BRIN)
  Substantial performance improvements for sorting
  Substantial performance improvements for multi-CPU machines
2016-02-25 21:37:35 +00:00

24 lines
870 B
Text

$NetBSD: patch-src_backend_Makefile,v 1.1 2016/02/25 21:37:35 tnn Exp $
--- src/backend/Makefile.orig 2014-12-16 01:07:34.000000000 +0000
+++ src/backend/Makefile
@@ -17,6 +17,10 @@ subdir = src/backend
top_builddir = ../..
include $(top_builddir)/src/Makefile.global
+CFLAGS+= $(DL_CFLAGS)
+LDFLAGS+= $(DL_LDFLAGS)
+LIBS+= $(DL_LIBS)
+
SUBDIRS = access bootstrap catalog parser commands executor foreign lib libpq \
main nodes optimizer port postmaster regex replication rewrite \
storage tcop tsearch utils $(top_builddir)/src/timezone
@@ -121,6 +125,8 @@ catalog/schemapg.h: | submake-schemapg
$(top_builddir)/src/port/libpgport_srv.a: | submake-libpgport
+$(top_builddir)/src/common/libpgcommon_srv.a: | submake-libpgport
+
# The postgres.o target is needed by the rule in Makefile.global that
# creates the exports file when MAKE_EXPORTS = true.