embedded server (by PKG_OPTION). For release MySQL 5.1 specific information please refer: http://dev.mysql.com/doc/refman/5.1/en/mysql-nutshell.html MySQL is a SQL (Structured Query Language) database server. SQL is the most popular database language in the world. MySQL is a client-server implementation that consists of a server daemon `mysqld' and many different client programs/libraries. The main goals of MySQL are speed and robustness. The base upon which MySQL is built is a set of routines that have been used in a highly demanding production environment for many years. While MySQL is still in development it already offers a rich and highly useful function set. The official way to pronounce 'MySQL' is 'My Ess Que Ell' (Not MY-SEQUEL). This package contains the MySQL server programs and libraries including embedded server (by PKG_OPTION).
32 lines
1.2 KiB
Text
32 lines
1.2 KiB
Text
$NetBSD: patch-ar,v 1.1.1.1 2010/03/04 16:28:58 taca Exp $
|
|
|
|
--- tests/Makefile.in.orig 2010-02-04 11:46:45.000000000 +0000
|
|
+++ tests/Makefile.in
|
|
@@ -85,7 +85,7 @@ insert_test_LDADD = $(LDADD)
|
|
am_mysql_client_test_OBJECTS = mysql_client_test.$(OBJEXT) \
|
|
my_memmem.$(OBJEXT)
|
|
mysql_client_test_OBJECTS = $(am_mysql_client_test_OBJECTS)
|
|
-am__DEPENDENCIES_1 = $(LIBMYSQLCLIENT_LA)
|
|
+am__DEPENDENCIES_1 =
|
|
am__DEPENDENCIES_2 =
|
|
mysql_client_test_DEPENDENCIES = $(am__DEPENDENCIES_1) \
|
|
$(am__DEPENDENCIES_2)
|
|
@@ -95,7 +95,7 @@ select_test_LDADD = $(LDADD)
|
|
thread_test_SOURCES = thread_test.c
|
|
thread_test_OBJECTS = thread_test.$(OBJEXT)
|
|
thread_test_LDADD = $(LDADD)
|
|
-thread_test_DEPENDENCIES = $(LIBMYSQLCLIENT_LA)
|
|
+thread_test_DEPENDENCIES =
|
|
DEFAULT_INCLUDES = -I.@am__isrc@ -I$(top_builddir)/include
|
|
depcomp = $(SHELL) $(top_srcdir)/depcomp
|
|
am__depfiles_maybe = depfiles
|
|
@@ -437,8 +437,7 @@ EXTRA_DIST = auto_increment.res auto_inc
|
|
INCLUDES = -I$(top_builddir)/include -I$(top_srcdir)/include \
|
|
$(openssl_includes)
|
|
|
|
-LDADD = @CLIENT_EXTRA_LDFLAGS@ \
|
|
- $(LIBMYSQLCLIENT_LA)
|
|
+LDADD = @CLIENT_EXTRA_LDFLAGS@ -lmysqlclient
|
|
|
|
mysql_client_test_LDADD = $(LDADD) $(CXXLDFLAGS)
|
|
mysql_client_test_SOURCES = mysql_client_test.c\
|