3fd37557f7
* Set LICENSE. Changelog: http://mozilla.6506.n7.nabble.com/ANNOUNCE-NSPR-4-10-Release-td280660.html -------------- NSPR 4.10 has the following bug fixes: * Bug 331169: Obviate PR_Sleep before PR_GetConnectStatus on Windows. Fixed by Brian Smith. * Bug 687033: Support Windows/arm. Fixed by Makoto Kato (partially checked in). * Bug 687033: Remove WINCE and Win9x support partially. * Bug 844513: Add AddressSanitizer (ASan) memory check annotations to PLArena. Fixed by Mats Palmgren. * Bug 849089: Simple changes to make NSPR's configure.in work with the current version of autoconf. * Bug 856196: Fix compiler warnings and clean up code in NSPR 4.10. * Bug 859066: Fix warning in nsprpub/pr/src/misc/prnetdb.c. * Bug 859830: Deprecate ANDROID_VERSION in favor of android/api-level.h. Fixed by Vicamo Yang. * Bug 861434: Make PR_SetThreadPriority() change priorities relatively to the main process instead of using absolute values on Linux. Fixed by Gabriele Svelto. * Bug 871064L: _PR_InitThreads() should not call PR_SetThreadPriority.
13 lines
634 B
C
13 lines
634 B
C
$NetBSD: patch-nsprpub_pr_src_pthreads_ptsynch.c,v 1.3 2013/07/20 08:57:20 ryoon Exp $
|
|
|
|
--- nsprpub/pr/src/pthreads/ptsynch.c.orig 2012-03-06 13:14:21.000000000 +0000
|
|
+++ nspr/pr/src/pthreads/ptsynch.c
|
|
@@ -810,7 +810,7 @@ PR_IMPLEMENT(PRStatus) PR_DeleteSemaphor
|
|
*/
|
|
#if (defined(__GNU_LIBRARY__) && !defined(_SEM_SEMUN_UNDEFINED)) \
|
|
|| defined(FREEBSD) || defined(OPENBSD) || defined(BSDI) \
|
|
- || defined(DARWIN) || defined(SYMBIAN)
|
|
+ || defined(DARWIN) || defined(SYMBIAN) || defined(__DragonFly__)
|
|
/* union semun is defined by including <sys/sem.h> */
|
|
#else
|
|
/* according to X/OPEN we have to define it ourselves */
|