40 lines
2.1 KiB
Text
40 lines
2.1 KiB
Text
$NetBSD: patch-al,v 1.1 2006/10/14 02:18:37 rillig Exp $
|
|
|
|
--- configure.in.orig 2004-04-14 05:39:12.000000000 +0200
|
|
+++ configure.in 2006-10-14 04:16:47.000000000 +0200
|
|
@@ -107,7 +107,7 @@ TK_LIB_STATIC=${TKCONF_PATH}/libtk${TK_V
|
|
# Check for the TkStep libraries (if needed)...
|
|
#
|
|
|
|
-if test "$ENABLE_TKSTEP" == "yes" ; then
|
|
+if test "$ENABLE_TKSTEP" = "yes" ; then
|
|
TK_LIB_SPEC="-ltkstep -lXpm -ltiff"
|
|
AC_MSG_NOTICE([will link using TkStep libraries])
|
|
fi
|
|
@@ -120,7 +120,7 @@ AC_MSG_CHECKING(version of Tcl)
|
|
AC_MSG_RESULT($TCL_VERSION)
|
|
if test "$TCL_MAJOR_VERSION" -lt 8; then
|
|
echo
|
|
- if test "$ENABLE_UNSUPPORTED" == "yes" ; then
|
|
+ if test "$ENABLE_UNSUPPORTED" = "yes" ; then
|
|
AC_MSG_WARN([you may be attempting to use TkDesk 2.x with an unsupported version of Tcl. Good luck. Hope it works out for you.])
|
|
else
|
|
AC_MSG_ERROR([TkDesk version 2.x requires Tcl version 8 or higher. Please upgrade your Tcl or, if that is not possible, you might prefer to use TkDesk version 1.2 instead.])
|
|
@@ -131,7 +131,7 @@ AC_MSG_CHECKING(version of Tk)
|
|
AC_MSG_RESULT($TK_VERSION)
|
|
if test "$TK_MAJOR_VERSION" -lt 8; then
|
|
echo
|
|
- if test "$ENABLE_UNSUPPORTED" == "yes" ; then
|
|
+ if test "$ENABLE_UNSUPPORTED" = "yes" ; then
|
|
AC_MSG_WARN([you may be attempting to use TkDesk 2.x with an unsupported version of Tk. Good luck. Hope it works out for you.])
|
|
else
|
|
AC_MSG_ERROR([TkDesk version 2.x requires Tk version 8 or higher. Please upgrade your Tk or, if that is not possible, you might prefer to use TkDesk version 1.2 instead.])
|
|
@@ -167,7 +167,7 @@ if test $success = 1 ; then
|
|
AC_MSG_RESULT($ITCL_VERSION)
|
|
if test "$ITCL_MAJOR_VERSION" -ne 3; then
|
|
echo
|
|
- if test "$ENABLE_UNSUPPORTED" == "yes" ; then
|
|
+ if test "$ENABLE_UNSUPPORTED" = "yes" ; then
|
|
AC_MSG_WARN([you may be attempting to use TkDesk 2.x with an unsupported version of Itcl. Good luck. Hope it works out for you.])
|
|
else
|
|
AC_MSG_ERROR([found Itcl, but it appears to be the wrong version. TkDesk 2.x requires itcl 3.x to be installed. Please get it from: http://www.incrtcl.sourceforge.net.])
|