a100f5d455
Closes pkg/14728 from Mark Davies <mark@mcs.vuw.ac.nz>. Changes from him with updates from myself. From www.kde.org... The principal improvements over KDE 2.2.1, release two months ago, include: o security-related - SSL certificate loading - symlink vulnerability in .wmrc access by KDM introduced in 2.2 - security problem with eFax (used by klprfax) - potential problem in PAM invocation by KDM - potential harmful side-effect of failed KDM session starts o new features - added support for CodeWeavers' CrossOver plug-in (provides support for QuickTime, etc.) - added support for the wheelmouse for scrolling through the KGhostview PS/PDF viewer component - ability to search for multiple patterns at a time in the file search dialog - debugging multi-threaded applications with KDevelop o improvements/fixes - handling of HTTP links that redirect to FTP - POST using SSL through a proxy and sending headers through proxies - saving of recently-selected files in the file dialog - handling of non-ASCII characters over SMB - toolbar button captions with certain styles - selecting items with the mouse in Konqueror - sorting in Konqueror's textview - saving current settings as a theme in the theme manager - crashes in KMail with certain mails - crash on invoking the KDM chooser - non-Latin languages with KDevelop performance - icon loading optimized - file dialog speedups - stop spinning SMB client processes - handling of large files in Kate
150 lines
7.3 KiB
Text
150 lines
7.3 KiB
Text
$NetBSD: patch-aw,v 1.2 2001/12/03 15:37:21 skrll Exp $
|
|
|
|
--- kio/http/Makefile.in.orig Tue Nov 13 20:57:18 2001
|
|
+++ kio/http/Makefile.in
|
|
@@ -268,19 +268,22 @@
|
|
####### Files
|
|
|
|
bin_PROGRAMS = kio_http_cache_cleaner
|
|
-lib_LTLIBRARIES = kio_http_cache_cleaner.la
|
|
+lib_LTLIBRARIES = libkio_http_cache_cleaner_main.la kio_http_cache_cleaner.la
|
|
kde_module_LTLIBRARIES = kio_http.la
|
|
|
|
kio_http_la_SOURCES = http.cc
|
|
kio_http_la_LIBADD = ../libkio.la $(LIBZ)
|
|
kio_http_la_LDFLAGS = $(all_libraries) -module $(KDE_PLUGIN)
|
|
|
|
-kio_http_cache_cleaner_SOURCES = dummy.cpp
|
|
-kio_http_cache_cleaner_LDADD = kio_http_cache_cleaner.la
|
|
+kio_http_cache_cleaner_SOURCES = http_cache_cleaner_main.cpp
|
|
+kio_http_cache_cleaner_LDADD = libkio_http_cache_cleaner_main.la
|
|
kio_http_cache_cleaner_LDFLAGS = $(KDE_RPATH)
|
|
|
|
-kio_http_cache_cleaner_la_SOURCES = http_cache_cleaner.cpp
|
|
-kio_http_cache_cleaner_la_LIBADD = $(LIB_KIO)
|
|
+libkio_http_cache_cleaner_main_la_SOURCES = http_cache_cleaner.cpp
|
|
+libkio_http_cache_cleaner_main_la_LIBADD = $(LIB_KIO)
|
|
+
|
|
+kio_http_cache_cleaner_la_SOURCES = http_cache_cleaner_main.cpp
|
|
+kio_http_cache_cleaner_la_LIBADD = libkio_http_cache_cleaner_main.la
|
|
kio_http_cache_cleaner_la_LDFLAGS = -module -avoid-version
|
|
|
|
noinst_HEADERS = http.h
|
|
@@ -300,17 +303,23 @@
|
|
#>- kio_http_la_OBJECTS = http.lo
|
|
#>+ 1
|
|
kio_http_la_OBJECTS = http.lo
|
|
-kio_http_cache_cleaner_la_DEPENDENCIES =
|
|
-#>- kio_http_cache_cleaner_la_OBJECTS = http_cache_cleaner.lo
|
|
+libkio_http_cache_cleaner_main_la_LDFLAGS =
|
|
+libkio_http_cache_cleaner_main_la_DEPENDENCIES =
|
|
+#>- libkio_http_cache_cleaner_main_la_OBJECTS = http_cache_cleaner.lo
|
|
+#>+ 1
|
|
+libkio_http_cache_cleaner_main_la_OBJECTS = http_cache_cleaner.lo
|
|
+kio_http_cache_cleaner_la_DEPENDENCIES = \
|
|
+ libkio_http_cache_cleaner_main.la
|
|
+#>- kio_http_cache_cleaner_la_OBJECTS = http_cache_cleaner_main.lo
|
|
#>+ 1
|
|
-kio_http_cache_cleaner_la_OBJECTS = http_cache_cleaner.lo
|
|
+kio_http_cache_cleaner_la_OBJECTS = http_cache_cleaner_main.lo
|
|
bin_PROGRAMS = kio_http_cache_cleaner$(EXEEXT)
|
|
PROGRAMS = $(bin_PROGRAMS)
|
|
|
|
-#>- kio_http_cache_cleaner_OBJECTS = dummy.$(OBJEXT)
|
|
+#>- kio_http_cache_cleaner_OBJECTS = http_cache_cleaner_main.$(OBJEXT)
|
|
#>+ 1
|
|
-kio_http_cache_cleaner_OBJECTS = dummy.$(OBJEXT)
|
|
-kio_http_cache_cleaner_DEPENDENCIES = kio_http_cache_cleaner.la
|
|
+kio_http_cache_cleaner_OBJECTS = http_cache_cleaner_main.$(OBJEXT)
|
|
+kio_http_cache_cleaner_DEPENDENCIES = libkio_http_cache_cleaner_main.la
|
|
CXXFLAGS = @CXXFLAGS@
|
|
#>- CXXCOMPILE = $(CXX) $(DEFS) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CXXFLAGS) $(CXXFLAGS)
|
|
#>+ 1
|
|
@@ -331,15 +340,15 @@
|
|
|
|
#>- DISTFILES = $(DIST_COMMON) $(SOURCES) $(HEADERS) $(TEXINFOS) $(EXTRA_DIST)
|
|
#>+ 4
|
|
-KDE_DIST=README.http_cache_cleaner https.protocol rfc2616.txt rfc2617.txt http.protocol http_cache_cleaner.desktop
|
|
+KDE_DIST=README.http_cache_cleaner http_cache_cleaner.desktop rfc2617.txt http.protocol https.protocol rfc2616.txt
|
|
|
|
DISTFILES= $(DIST_COMMON) $(SOURCES) $(HEADERS) $(TEXINFOS) $(EXTRA_DIST) $(KDE_DIST)
|
|
|
|
|
|
TAR = tar
|
|
GZIP_ENV = --best
|
|
-SOURCES = $(kio_http_la_SOURCES) $(kio_http_cache_cleaner_la_SOURCES) $(kio_http_cache_cleaner_SOURCES)
|
|
-OBJECTS = $(kio_http_la_OBJECTS) $(kio_http_cache_cleaner_la_OBJECTS) $(kio_http_cache_cleaner_OBJECTS)
|
|
+SOURCES = $(kio_http_la_SOURCES) $(libkio_http_cache_cleaner_main_la_SOURCES) $(kio_http_cache_cleaner_la_SOURCES) $(kio_http_cache_cleaner_SOURCES)
|
|
+OBJECTS = $(kio_http_la_OBJECTS) $(libkio_http_cache_cleaner_main_la_OBJECTS) $(kio_http_cache_cleaner_la_OBJECTS) $(kio_http_cache_cleaner_OBJECTS)
|
|
|
|
#>- all: all-redirect
|
|
#>+ 1
|
|
@@ -457,6 +466,9 @@
|
|
@KDE_USE_CLOSURE_FALSE@kio_http.la: $(kio_http_la_OBJECTS) $(kio_http_la_DEPENDENCIES)
|
|
$(CXXLINK) -rpath $(kde_moduledir) $(kio_http_la_LDFLAGS) $(kio_http_la_OBJECTS) $(kio_http_la_LIBADD) $(LIBS)
|
|
|
|
+libkio_http_cache_cleaner_main.la: $(libkio_http_cache_cleaner_main_la_OBJECTS) $(libkio_http_cache_cleaner_main_la_DEPENDENCIES)
|
|
+ $(CXXLINK) -rpath $(libdir) $(libkio_http_cache_cleaner_main_la_LDFLAGS) $(libkio_http_cache_cleaner_main_la_OBJECTS) $(libkio_http_cache_cleaner_main_la_LIBADD) $(LIBS)
|
|
+
|
|
kio_http_cache_cleaner.la: $(kio_http_cache_cleaner_la_OBJECTS) $(kio_http_cache_cleaner_la_DEPENDENCIES)
|
|
$(CXXLINK) -rpath $(libdir) $(kio_http_cache_cleaner_la_LDFLAGS) $(kio_http_cache_cleaner_la_OBJECTS) $(kio_http_cache_cleaner_la_LIBADD) $(LIBS)
|
|
|
|
@@ -739,9 +751,6 @@
|
|
maintainer-clean-generic clean mostlyclean distclean maintainer-clean
|
|
|
|
|
|
-dummy.cpp:
|
|
- echo > dummy.cpp
|
|
-
|
|
# Tell versions [3.59,3.63) of GNU make to not export all variables.
|
|
# Otherwise a system limit (for SysV at least) may be exceeded.
|
|
.NOEXPORT:
|
|
@@ -781,11 +790,23 @@
|
|
rm -f kio_http_la.all_cc.final kio_http_la.all_cc.files
|
|
|
|
#>+ 11
|
|
-kio_http_cache_cleaner_la.all_cpp.cpp: $(srcdir)/Makefile.in $(srcdir)/http_cache_cleaner.cpp
|
|
+libkio_http_cache_cleaner_main_la.all_cpp.cpp: $(srcdir)/Makefile.in $(srcdir)/http_cache_cleaner.cpp
|
|
+ @echo 'creating libkio_http_cache_cleaner_main_la.all_cpp.cpp ...'; \
|
|
+ rm -f libkio_http_cache_cleaner_main_la.all_cpp.files libkio_http_cache_cleaner_main_la.all_cpp.final; \
|
|
+ echo "#define KDE_USE_FINAL 1" >> libkio_http_cache_cleaner_main_la.all_cpp.final; \
|
|
+ for file in http_cache_cleaner.cpp ; do \
|
|
+ echo "#include \"$$file\"" >> libkio_http_cache_cleaner_main_la.all_cpp.files; \
|
|
+ test ! -f $(srcdir)/$$file || egrep '^#pragma +implementation' $(srcdir)/$$file >> libkio_http_cache_cleaner_main_la.all_cpp.final; \
|
|
+ done; \
|
|
+ cat libkio_http_cache_cleaner_main_la.all_cpp.final libkio_http_cache_cleaner_main_la.all_cpp.files > libkio_http_cache_cleaner_main_la.all_cpp.cpp; \
|
|
+ rm -f libkio_http_cache_cleaner_main_la.all_cpp.final libkio_http_cache_cleaner_main_la.all_cpp.files
|
|
+
|
|
+#>+ 11
|
|
+kio_http_cache_cleaner_la.all_cpp.cpp: $(srcdir)/Makefile.in $(srcdir)/http_cache_cleaner_main.cpp
|
|
@echo 'creating kio_http_cache_cleaner_la.all_cpp.cpp ...'; \
|
|
rm -f kio_http_cache_cleaner_la.all_cpp.files kio_http_cache_cleaner_la.all_cpp.final; \
|
|
echo "#define KDE_USE_FINAL 1" >> kio_http_cache_cleaner_la.all_cpp.final; \
|
|
- for file in http_cache_cleaner.cpp ; do \
|
|
+ for file in http_cache_cleaner_main.cpp ; do \
|
|
echo "#include \"$$file\"" >> kio_http_cache_cleaner_la.all_cpp.files; \
|
|
test ! -f $(srcdir)/$$file || egrep '^#pragma +implementation' $(srcdir)/$$file >> kio_http_cache_cleaner_la.all_cpp.final; \
|
|
done; \
|
|
@@ -793,11 +814,11 @@
|
|
rm -f kio_http_cache_cleaner_la.all_cpp.final kio_http_cache_cleaner_la.all_cpp.files
|
|
|
|
#>+ 11
|
|
-kio_http_cache_cleaner.all_cpp.cpp: $(srcdir)/Makefile.in dummy.cpp
|
|
+kio_http_cache_cleaner.all_cpp.cpp: $(srcdir)/Makefile.in $(srcdir)/http_cache_cleaner_main.cpp
|
|
@echo 'creating kio_http_cache_cleaner.all_cpp.cpp ...'; \
|
|
rm -f kio_http_cache_cleaner.all_cpp.files kio_http_cache_cleaner.all_cpp.final; \
|
|
echo "#define KDE_USE_FINAL 1" >> kio_http_cache_cleaner.all_cpp.final; \
|
|
- for file in dummy.cpp ; do \
|
|
+ for file in http_cache_cleaner_main.cpp ; do \
|
|
echo "#include \"$$file\"" >> kio_http_cache_cleaner.all_cpp.files; \
|
|
test ! -f $(srcdir)/$$file || egrep '^#pragma +implementation' $(srcdir)/$$file >> kio_http_cache_cleaner.all_cpp.final; \
|
|
done; \
|
|
@@ -806,7 +827,7 @@
|
|
|
|
#>+ 3
|
|
clean-final:
|
|
- -rm -f kio_http_la.all_cc.cc kio_http_cache_cleaner_la.all_cpp.cpp kio_http_cache_cleaner.all_cpp.cpp
|
|
+ -rm -f kio_http_la.all_cc.cc libkio_http_cache_cleaner_main_la.all_cpp.cpp kio_http_cache_cleaner_la.all_cpp.cpp kio_http_cache_cleaner.all_cpp.cpp
|
|
|
|
#>+ 2
|
|
final:
|