a62b3e67a6
With apologies to Al I wouldn't know where to start with a summary of the changes between 2.1 and 2.2.1 - there are just too many. A couple of hopefully static URLS that contain useful information are http://www.kde.org/announcements/changelog2_1to2_2.html http://www.kde.org/announcements/changelog2_2to2_2_1.html Support for a.out for kde{libs,base} added by me. The libtool/a.out combination doesn't like the linking of modules into binaries. A better way of doing this will appear in future versions of KDE/pkgsrc.
39 lines
1.2 KiB
Text
39 lines
1.2 KiB
Text
$NetBSD: patch-az,v 1.1 2001/10/15 22:46:24 skrll Exp $
|
|
|
|
--- kio/http/kcookiejar/Makefile.am.orig Fri May 11 02:23:55 2001
|
|
+++ kio/http/kcookiejar/Makefile.am
|
|
@@ -6,17 +6,21 @@
|
|
####### Files
|
|
|
|
bin_PROGRAMS = kcookiejar
|
|
-lib_LTLIBRARIES = kcookiejar.la
|
|
+lib_LTLIBRARIES = libkcookiejar_main.la kcookiejar.la
|
|
|
|
-kcookiejar_la_SOURCES = kcookiejar.cpp kcookieserver.cpp \
|
|
+libkcookiejar_main_la_SOURCES = kcookiejar.cpp kcookieserver.cpp \
|
|
kcookieserver.skel kcookiewin.cpp \
|
|
kcookiewin.h main.cpp
|
|
-kcookiejar_la_METASOURCES = AUTO
|
|
+libkcookiejar_main_la_METASOURCES = AUTO
|
|
+libkcookiejar_main_la_LDFLAGS = $(all_libraries)
|
|
+libkcookiejar_main_la_LIBADD = $(LIB_KIO)
|
|
+
|
|
+kcookiejar_la_SOURCES = kcookiejar_main.cpp
|
|
kcookiejar_la_LDFLAGS = $(all_libraries) -module -avoid-version
|
|
-kcookiejar_la_LIBADD = $(LIB_KIO)
|
|
+kcookiejar_la_LIBADD = libkcookiejar_main.la
|
|
|
|
-kcookiejar_SOURCES = dummy.cpp
|
|
-kcookiejar_LDADD = kcookiejar.la
|
|
+kcookiejar_SOURCES = kcookiejar_main.cpp
|
|
+kcookiejar_LDADD = libkcookiejar_main.la
|
|
kcookiejar_LDFLAGS = $(all_libraries) $(KDE_RPATH)
|
|
|
|
services_DATA = kcookiejar.desktop
|
|
@@ -24,6 +28,3 @@
|
|
|
|
update_DATA = kcookiescfg.upd
|
|
updatedir = $(kde_datadir)/kconf_update
|
|
-
|
|
-dummy.cpp:
|
|
- echo > dummy.cpp
|