Pkgsrc changes: - Adjust some patches - Remove patches integrated upstream - Use Perl's "Policy.sh" framework (along the way remove some patches) - Link in an enterprise friendly way on HPUX - in buildlink3.mk bump minimum required pkgsrc Perl version to 5.12.0 - placate some pkglint warnings Upstream changes: - From version 5.12.1 announce This release contains minor bug fixes and updates of several core modules, as well as minor documentation updates. It should be fully backward compatible with Perl 5.12.0. - From version 5.12.0 announce: Perl 5.12.0 represents approximately two years of development since version 5.10.0 and contains over 750,000 lines of changes across over 3,000 files from over 200 authors and committers. [...] Notable changes in Perl 5.12 include: * Perl now conforms much more closely to the Unicode standard. Additionally, this release includes an upgrade to version 5.2 of the standard. * New experimental APIs allow developers to extend Perl with "pluggable" keywords and syntax. * Perl now has a better sense of time and will be able to keep accurate time well past the "Y2038" barrier. * New syntax allows developers to specify package version numbers directly in "package" statements * Perl now warns the user about the use of deprecated features by default. - For a complete list of changes see included perl5120delta(1) and perl5121delta(1) or http://perldoc.perl.org/perl5120delta.html and http://perldoc.perl.org/perl5121delta.html
43 lines
1.3 KiB
Text
43 lines
1.3 KiB
Text
--- Policy_sh.SH.orig 2010-04-26 08:08:20.000000000 +0000
|
|
+++ Policy_sh.SH 2010-05-27 09:34:44.000000000 +0000
|
|
@@ -165,7 +165,7 @@
|
|
|
|
# We don't know what to do with these yet.
|
|
html1dir) dflt='' ;;
|
|
- htm31dir) dflt='' ;;
|
|
+ html3dir) dflt='' ;;
|
|
|
|
# Directories for site-specific add-on files
|
|
sitebin) dflt=$siteprefix/bin ;;
|
|
@@ -184,11 +184,11 @@
|
|
;;
|
|
sitearch) dflt="$sitelib/$archname" ;;
|
|
|
|
- siteman1) dflt="$siteprefix/man/man1" ;;
|
|
- siteman3) dflt="$siteprefix/man/man3" ;;
|
|
+ siteman1dir) dflt="$siteprefix/man/man1" ;;
|
|
+ siteman3dir) dflt="$siteprefix/man/man3" ;;
|
|
# We don't know what to do with these yet.
|
|
- sitehtml1) dflt='' ;;
|
|
- sitehtm31dir) dflt='' ;;
|
|
+ sitehtml1dir) dflt='' ;;
|
|
+ sitehtml3dir) dflt='' ;;
|
|
|
|
# Directories for vendor-supplied add-on files
|
|
# These are all usually empty.
|
|
@@ -213,11 +213,11 @@
|
|
;;
|
|
vendorarch) dflt="$vendorlib/$archname" ;;
|
|
|
|
- vendorman1) dflt="$vendorprefix/man/man1" ;;
|
|
- vendorman3) dflt="$vendorprefix/man/man3" ;;
|
|
+ vendorman1dir) dflt="$vendorprefix/man/man1" ;;
|
|
+ vendorman3dir) dflt="$vendorprefix/man/man3" ;;
|
|
# We don't know what to do with these yet.
|
|
- vendorhtml1) dflt='' ;;
|
|
- vendorhtm3) dflt='' ;;
|
|
+ vendorhtml1dir) dflt='' ;;
|
|
+ vendorhtml3dir) dflt='' ;;
|
|
|
|
esac # End of vendorprefix != ''
|
|
fi
|