pkgsrc/security/fwbuilder/patches/patch-configure.in
adam b8d55b79dc Changes 4.1.3:
This version comes with the following usability enhancements:
* Added checkbox to the Preferences dialog, this checkbox turns off some
  tooltips that can be annoying for users who are sufficiently familiar with
  the GUI.
* Added a tab "Policy Rule" to the "Objects" page of the global preferences
  dialog; checkbox in this tab allows the user to choose whether new policy
  rules should be created with logging turned on or off.
The major bug fixes in this release include:
* Fixed installer issue for Windows users that use Putty sessions. Built-in
  policy installer can use putty session on Windows when it runs pscp.exe
  utility to copy generated script to the firewall
* Fixed bug in the generated iptables script that made it to not configure
  broadcast address when it added ip addresses to interfaces.
* Several bugs that affected cluster configurations were fixed.
2011-04-12 13:41:17 +00:00

52 lines
1.4 KiB
Text

$NetBSD: patch-configure.in,v 1.1 2011/04/12 13:44:03 adam Exp $
Fix MANDIR and DEFAULT_RES_DIR.
--- configure.in.orig 2011-04-12 06:15:34.000000000 +0000
+++ configure.in
@@ -325,15 +325,15 @@ case ${host} in
*-*-darwin*)
OS=MacOSX
OS_MACOSX=1
- MANDIR="${PREFIX}/share/man/"
+ MANDIR="${PREFIX}/man/"
AC_MSG_RESULT(MacOSX)
- DEFAULT_RES_DIR="../Resources"
+ DEFAULT_RES_DIR="${PREFIX}/share/fwbuilder-${VERSION}"
;;
*-*-solaris*)
OS=Solaris
OS_SOLARIS=1
- MANDIR="${PREFIX}/share/man/"
+ MANDIR="${PREFIX}/man/"
AC_MSG_RESULT(Solaris)
DEFAULT_RES_DIR="${PREFIX}/share/fwbuilder-${VERSION}"
;;
@@ -362,7 +362,7 @@ case ${host} in
else
DISTRO="Unknown"
fi
- MANDIR="${PREFIX}/share/man/"
+ MANDIR="${PREFIX}/man/"
AC_MSG_RESULT($DISTRO GNU/kFreeBSD)
DEFAULT_RES_DIR="${PREFIX}/share/fwbuilder-${VERSION}"
;;
@@ -388,7 +388,7 @@ case ${host} in
else
DISTRO="Unknown"
fi
- MANDIR="${PREFIX}/share/man/"
+ MANDIR="${PREFIX}/man/"
ICONSDIR="${DATADIR}/icons/hicolor/"
AC_MSG_RESULT($DISTRO Linux)
;;
@@ -397,7 +397,7 @@ case ${host} in
OS=Unknown
OS_UNKNOWN=1
DISTRO=Unknown
- MANDIR="${PREFIX}/share/man/"
+ MANDIR="${PREFIX}/man/"
AC_MSG_RESULT(Unknown)
DEFAULT_RES_DIR="${PREFIX}/share/fwbuilder-${VERSION}"
;;