a getline() function taken from nbftp--bothering with gnulib was too annoying. It works for me on NetBSD-current, but please let me know if there are any problems. I've also extended the check for sched_get_priority_max(3)--both here and in audio/moc--to look in librt prior to giving up. This allows moc to run with realtime priority on NetBSD-current; unfortunately, presently this requires root perms.
16 lines
546 B
Text
16 lines
546 B
Text
$NetBSD: patch-ab,v 1.1.1.1 2008/04/07 16:10:37 bjs Exp $
|
|
|
|
--- configure.in.orig 2008-02-25 17:37:30.000000000 -0500
|
|
+++ configure.in
|
|
@@ -49,7 +49,10 @@ AC_CHECK_HEADERS([fcntl.h string.h strin
|
|
AC_MSG_ERROR([Can't find required header files.]))
|
|
AC_CHECK_HEADERS([sys/select.h inttypes.h limits.h stdint.h])
|
|
|
|
-AC_CHECK_FUNCS([sched_get_priority_max])
|
|
+AC_CHECK_FUNCS([sched_get_priority_max], ,
|
|
+ [AC_CHECK_LIB([rt],
|
|
+ [sched_get_priority_max],
|
|
+ [EXTRA_LIBS="$EXTRA_LIBS -lrt"])])
|
|
|
|
dnl langinfo
|
|
AC_CHECK_HEADERS([langinfo.h])
|