2597964706
1) Replace custom tarball with Adacore's GPL 2012 release 2) Update license to GPLv3 3) Remove lang/gnat-aux dependency 4) USE_LANGUAGES+= ada (invokes lang/gcc-aux dependency) 5) Update buildlink3.mk to require GPL 2012 version 6) Restore use of pkgsrc wrappers 7) Add Library_Option "-R" support which ignores all automatically generated rpaths* which point to the WRKOBJDIR. DESTDIR isn't supported by GPRBuild, so this rpath disabling is necessary to avoid references to work directories. * gcc and adalib rpaths are excluded with -R option. 8) This Library_Option "-R" matches the same modification added to lang/gcc-aux and lang/gnat-aux's project handler. 9) This modification is required to fix www/aws rpath issues which appears with recent changes to PKG_DEVELOPER=yes checks.
39 lines
1.4 KiB
Ada
39 lines
1.4 KiB
Ada
$NetBSD: patch-src_gprlib.adb,v 1.1 2012/07/08 20:08:42 marino Exp $
|
|
|
|
--- src/gprlib.adb.orig 2012-05-10 13:59:05.000000000 +0000
|
|
+++ src/gprlib.adb
|
|
@@ -390,6 +390,11 @@ procedure Gprlib is
|
|
|
|
Separate_Run_Path_Options : Boolean := False;
|
|
|
|
+ Rpath_Disabled : Boolean := False;
|
|
+ -- If -R is passed through the library options for the linker, it will
|
|
+ -- prevent the implemented libraries portion of the rpath switch from
|
|
+ -- being built, even if the linker is capable of supporting rpath.
|
|
+
|
|
Rpath : String_List_Access := null;
|
|
-- Allocated only if Path Option is supported
|
|
|
|
@@ -1009,7 +1014,12 @@ begin
|
|
Use_GNAT_Lib := False;
|
|
end if;
|
|
|
|
- Library_Options_Table.Append (new String'(Line (1 .. Last)));
|
|
+ if Line (1 .. Last) = "-R" then
|
|
+ Rpath_Disabled := True;
|
|
+ else
|
|
+ Library_Options_Table.Append
|
|
+ (new String'(Line (1 .. Last)));
|
|
+ end if;
|
|
|
|
when Library_Path =>
|
|
Osint.Fail ("library path should not be specified");
|
|
@@ -2127,7 +2137,7 @@ begin
|
|
Library_Switches_Table.Append
|
|
(new String'("-L" & Imported_Library_Directories.Table (J).all));
|
|
|
|
- if Path_Option /= null then
|
|
+ if not Rpath_Disabled and then Path_Option /= null then
|
|
Add_Rpath (Imported_Library_Directories.Table (J));
|
|
end if;
|
|
|