pkgsrc/net/ORBit/patches/patch-ae
agc 52ed484e2d Upgrade to version 0.5.15 from 0.5.13nb1 of the ORBit package - diffs
provided by Thomas Klausner.

Diffs from previous version:

2002-03-20  Michael Meeks  <michael@ximian.com>
        * configure.in: copy the autoconf macro into here so we
        can rely on it not changing across autoconf versions.
2002-03-11  Michael Meeks  <michael@ximian.com>
        * src/IIOP/giop-msg-buffer.c
        kill #define writev mess.
        (giop_send_buffer_write): handle EINTR, handle EAGAIN
        correctly, handle short writev's correctly, test
        thorougly.
        * src/ORBitutil/compat.c (g_writev): kill this
        abomination.
2002-02-11  Sebastian Wilhelmi  <wilhelmi@ira.uka.de>
        * src/orb/allocators.h, src/orb/allocators.c (ORBit_alloc_2,
        ORBit_free): Make the free marker really always sit directly in
        front of the memory block, not at some random lower position.
2002-02-09 Elliot Lee <sopwith@redhat.com>
        * src/ORBitutil/os-feature-alloca.h: Don't redefine alloca if it is already defined.
2002-01-27  Darin Adler  <darin@bentspoon.com>
        * test/everything/Makefile.am: Added -lm -- can't build without it.
2002-01-25  Mark McLoughlin  <mark@skynet.ie>
        * configure.in: (AC_CHECK_ALIGNOF): error out if an alignment
        is found to be zero.

Thomas thought that the modification to src/IIOP/giop-msg-buffer.c to
"kill #define writev mess" might mean that we could drop the
NetBSD-specific wrapper for writev(2), but sadly this isn't so -
configure undefines HAVE_LIMITED_WRITEV on NetBSD, and rightly so,
since IOV_MAX (1024) iovecs can be written, not 50.  However, we still
have the basic "attempt to send more than IOV_MAX iovecs and you get
EINVAL" problem with our writev(2) implementation.
2002-04-25 12:17:04 +00:00

13 lines
798 B
Text

$NetBSD: patch-ae,v 1.9 2002/04/25 12:17:05 agc Exp $
--- src/services/name/Makefile.in.orig Wed Mar 20 15:46:26 2002
+++ src/services/name/Makefile.in
@@ -126,7 +126,7 @@
DEPS = $(top_builddir)/src/orb/libORBit.la $(top_builddir)/src/ORBitutil/libORBitutil.la $(top_builddir)/src/IIOP/libIIOP.la libORBitCosNaming.la
-LDADDS = $(top_builddir)/src/orb/libORBit.la $(top_builddir)/src/IIOP/libIIOP.la $(top_builddir)/src/ORBitutil/libORBitutil.la libORBitCosNaming.la @GLIB_LIBS@ -lm
+LDADDS = $(top_builddir)/src/orb/libORBit.la $(top_builddir)/src/IIOP/libIIOP.la $(top_builddir)/src/ORBitutil/libORBitutil.la libORBitCosNaming.la @GLIB_LIBS@ -lm @LIB_WRAP@
#name-client.c boot.c orbit-name-server.c new-name-server.c: CosNaming.h