pkgsrc/net/bug-buddy/patches/patch-aa
jmcneill fc5080e9d6 Update bug-buddy to 2.26.0.
2.26.0
  * Don't hardcode a scrollkeeper check in the configure script.

2.25.91
  * Build correctly with --disable-eds.

2.25.2
  * Fix a segfault (Josseline Mouette).
  * Don't free uninitialized memory.

2.25.1 ("The Feel-Good vibe")
  * Drop libgnome and libgnomeui dependencies.
  * Make google-breakpad support optional (but enabled by default).
    Thanks to Sjoerd Simons.
  * Obtain the real path of the crashed process by looking in /proc.
    Thanks to Sam Morris and Matt Keenan.
  * Add an option to delete the included file after bug-buddy has
    processed it.
  * Implement a logger for pasting critical and fatal warnings in the
    stacktraces.
  * Include the loaded GTK+ modules in the stacktraces sent to bugzilla.
  * Update google-breakpad to SVN r290.
  * Compile with all the GLib/GTK+ deprecation flags.
2009-03-17 09:10:03 +00:00

32 lines
1.1 KiB
Text

$NetBSD: patch-aa,v 1.6 2009/03/17 09:10:03 jmcneill Exp $
--- configure.in.orig 2009-03-16 20:20:15.000000000 -0400
+++ configure.in
@@ -116,7 +116,7 @@ AM_CONDITIONAL(USE_GOOGLE_BREAKPAD, test
AM_CONDITIONAL(BREAKPAD_SOLARIS, test x$solaris = xyes)
AM_CONDITIONAL(BREAKPAD_LINUX, test x$linux = xyes)
-GDK_REQUIRED="x11 gdk-x11-2.0 >= 2.9"
+GDK_REQUIRED="gdk-x11-2.0 >= 2.9"
PKG_CHECK_MODULES(GNOME_BREAKPAD,
[
$GDK_REQUIRED
@@ -124,6 +124,18 @@ PKG_CHECK_MODULES(GNOME_BREAKPAD,
AC_SUBST(GNOME_BREAKPAD_CFLAGS)
AC_SUBST(GNOME_BREAKPAD_LIBS)
+PKG_CHECK_MODULES(X11, x11 >= $X11_REQUIRED_VERSION, [HAVE_X11=yes], [HAVE_X11=no])
+if test x$HAVE_X11 = xno; then
+ AC_PATH_XTRA
+ if test "x$no_x" = xyes; then
+ AC_MSG_ERROR(X11 and Xrandr development libraries not found);
+ else
+ XLIB_LIBS="$X_PRE_LIBS $X_LIBS -lX11 $X_EXTRA_LIBS"
+ XLIB_CFLAGS=$X_CFLAGS
+ fi
+fi
+GNOME_BREAKPAD_CFLAGS="$GNOME_BREAKPAD_CFLAGS $X11_CFLAGS $XLIB_CFLAGS"
+GNOME_BREAKPAD_LIBS="$GNOME_BREAKPAD_LIBS $X11_LIBS $XLIB_LIBS"
PKG_CHECK_MODULES(GNOME_CRASH, $GTK_REQUIRED)
AC_SUBST(GNOME_CRASH_CFLAGS)