MPQC is the Massively Parallel Quantum Chemistry Program. It computes properties of atoms and molecules from first principles using the time independent Schroedinger equation. It runs on a wide range of architectures ranging from single many-core computers to massively parallel computers. Its design is object oriented, using the C++ programming language. Capabilities * Closed shell, unrestricted and general restricted open shell Hartree-Fock energies and gradients * Closed shell, unrestricted and general restricted open shell density functional theory energies and gradients * Second order open shell perturbation theory (OPT2[2]) and Z-averaged perturbation theory (ZAPT2) energies. * Second order closed shell Moller-Plesset perturbation theory energies and gradients. * Second order Moller-Plesset perturbation theory including an R12/F12 correlation factor. Energies of closed- and open-shell systems are supported. * Explicitly-correlated R12/F12 coupled-cluster methods via interface to Psi3 code and via native (experimental) implementation. * Explicitly-correlated multireference methods (MRCI, CASPT2) via interfaces to GAMESS and MOLCAS codes. * Robust internal coordinate geometry optimizer that efficiently optimizes molecules with many degrees of freedom. Nearly arbitrary internal coordinate constraints can be handled.
45 lines
1.2 KiB
Text
45 lines
1.2 KiB
Text
$NetBSD: patch-configure.in,v 1.1.1.1 2013/03/16 12:43:26 asau Exp $
|
|
|
|
--- configure.in.orig 2006-03-22 18:04:54.000000000 +0000
|
|
+++ configure.in
|
|
@@ -488,7 +488,7 @@ AC_ARG_WITH(cca-chem-config,
|
|
CCA_CHEM_CONFIG=$withval
|
|
echo Using cca-chem-config: $withval
|
|
],[
|
|
- if test "$components" == "yes"; then
|
|
+ if test "$components" = "yes"; then
|
|
AC_PATH_PROG(CCA_CHEM_CONFIG,cca-chem-config,"not-found")
|
|
fi
|
|
]
|
|
@@ -747,7 +747,7 @@ case $target_cpu in
|
|
;;
|
|
esac
|
|
|
|
-if test X$GXX == Xyes; then
|
|
+if test X$GXX = Xyes; then
|
|
AC_MSG_CHECKING([for C++ cpu tuning flag])
|
|
AC_LANG_SAVE
|
|
AC_LANG_CPLUSPLUS
|
|
@@ -759,7 +759,7 @@ if test X$GXX == Xyes; then
|
|
AC_MSG_RESULT($cxx_tuneflag)
|
|
fi
|
|
|
|
-if test X$GCC == Xyes; then
|
|
+if test X$GCC = Xyes; then
|
|
AC_MSG_CHECKING([for C cpu tuning flag])
|
|
CFLAGS_SAV=$CFLAGS
|
|
CFLAGS="-mtune=$opt_target_cpu $CFLAGS_SAV"
|
|
@@ -1769,10 +1769,10 @@ AC_SUBST(ENABLESHARED)
|
|
|
|
dnl --------- CCA component configuration ---------
|
|
|
|
-if test $components == "yes"; then
|
|
+if test $components = "yes"; then
|
|
|
|
- if test $HAVE_MPI == "yes" &&
|
|
- test $HAVE_MPIPP == "no"; then
|
|
+ if test $HAVE_MPI = "yes" &&
|
|
+ test $HAVE_MPIPP = "no"; then
|
|
AC_MSG_ERROR([libmpi++ needed for mpi cca components])
|
|
fi
|
|
|