The Xen virtual machine monitor allows running several virtual machines on a single physical machine. The xentools33 package contains the tools to create, destroy and control the virtual machines. The xentools33 package contains the tools for Xen 3.3.x
45 lines
1.8 KiB
Text
45 lines
1.8 KiB
Text
$NetBSD: patch-ba,v 1.1.1.1 2008/08/07 20:26:58 cegger Exp $
|
|
|
|
--- python/Makefile.orig 2008-08-01 16:38:07.000000000 +0200
|
|
+++ python/Makefile
|
|
@@ -20,7 +20,7 @@ PODIR := xen/xm/messages
|
|
POTFILE := $(PODIR)/xen-xm.pot
|
|
I18NSRCFILES = $(shell find xen/xm/ -name '*.py')
|
|
CATALOGS = $(patsubst %,xen/xm/messages/%.mo,$(LINGUAS))
|
|
-NLSDIR = /usr/share/locale
|
|
+NLSDIR = $(PREFIX)/share/locale
|
|
|
|
.PHONY: build buildpy
|
|
buildpy: xsm.py
|
|
@@ -77,23 +77,23 @@ xsm.py:
|
|
ifndef XEN_PYTHON_NATIVE_INSTALL
|
|
install: LIBPATH=$(shell PYTHONPATH=xen/util python -c "import auxbin; print auxbin.libpath()")
|
|
install: install-messages install-dtd
|
|
- CC="$(CC)" CFLAGS="$(CFLAGS)" python setup.py install --home="$(DESTDIR)/usr" --prefix="" --force --install-lib="$(DESTDIR)$(LIBPATH)/python"
|
|
+ python setup.py install --root=${DESTDIR}
|
|
else
|
|
install: install-messages install-dtd
|
|
- CC="$(CC)" CFLAGS="$(CFLAGS)" python setup.py install --root="$(DESTDIR)" --force
|
|
+ python setup.py install --root=${DESTDIR}
|
|
endif
|
|
|
|
install-dtd: all
|
|
- $(INSTALL_DIR) $(DESTDIR)/usr/share/xen
|
|
- $(INSTALL_DATA) xen/xm/create.dtd $(DESTDIR)/usr/share/xen
|
|
+ $(BSD_INSTALL_DATA_DIR) $(DESTDIR)$(PREFIX)/share/xen
|
|
+ $(BSD_INSTALL_DATA) xen/xm/create.dtd $(DESTDIR)$(PREFIX)/share/xen
|
|
|
|
install-messages: all
|
|
set -e; if which $(MSGFMT) >/dev/null ; then \
|
|
- mkdir -p $(DESTDIR)$(NLSDIR); \
|
|
+ $(BSD_INSTALL_DATA_DIR) $(DESTDIR)$(NLSDIR); \
|
|
for l in $(LINGUAS); do \
|
|
- $(INSTALL_DIR) $(DESTDIR)$(NLSDIR)/$$l; \
|
|
- $(INSTALL_DIR) $(DESTDIR)$(NLSDIR)/$$l/LC_MESSAGES; \
|
|
- $(INSTALL_DATA) $(PODIR)/$$l.mo \
|
|
+ $(BSD_INSTALL_DATA_DIR) $(DESTDIR)$(NLSDIR)/$$l; \
|
|
+ $(BSD_INSTALL_DATA_DIR) $(DESTDIR)$(NLSDIR)/$$l/LC_MESSAGES; \
|
|
+ $(BSD_INSTALL_DATA) $(PODIR)/$$l.mo \
|
|
$(DESTDIR)$(NLSDIR)/$$l/LC_MESSAGES/$(POPACKAGE).mo; \
|
|
done ; \
|
|
fi
|