- support for newer Python versions - various bug fixes and security improvements - moved from LGPL to MIT license Based on the update by Christian Sturm in wip with additional fixes from me.
20 lines
851 B
Text
20 lines
851 B
Text
$NetBSD: patch-aa,v 1.3 2009/08/14 14:09:28 joerg Exp $
|
|
|
|
--- setup.py.orig 2009-08-14 15:48:39.000000000 +0200
|
|
+++ setup.py
|
|
@@ -525,11 +525,12 @@ if 'py2exe' in sys.argv:
|
|
"etc/mixminiond.conf"])],
|
|
}
|
|
elif sys.platform != 'win32':
|
|
+ import os
|
|
EXTRA = {
|
|
- 'data_files' : [("share/man/man1", ["doc/mixminion.1"]),
|
|
- ("share/man/man5", ["doc/mixminionrc.5",
|
|
+ 'data_files' : [( os.environ["PKGMANDIR"] + "/man1", ["doc/mixminion.1"]),
|
|
+ ( os.environ["PKGMANDIR"] + "/man5", ["doc/mixminionrc.5",
|
|
"doc/mixminiond.conf.5"]),
|
|
- ("share/man/man8", ["doc/mixminiond.8"])]
|
|
+ ( os.environ["PKGMANDIR"] + "/man8", ["doc/mixminiond.8"])]
|
|
}
|
|
else:
|
|
EXTRA = {}
|