52 lines
1.7 KiB
Text
52 lines
1.7 KiB
Text
$NetBSD: patch-ak,v 1.1.1.1 1999/05/11 13:56:53 bad Exp $
|
|
|
|
--- ui/Makefile.SH.orig Fri Apr 16 11:59:47 1999
|
|
+++ ui/Makefile.SH Sun May 9 23:17:38 1999
|
|
@@ -57,7 +57,7 @@
|
|
|
|
CFLAGS = $ccflags $optimize -I\$(TOP)/lib/ir $mccflags $embed_cflags
|
|
DPFLAGS = -I\$(TOP)/lib/ir $mccflags $embed_cflags
|
|
-LDFLAGS = -L\$(TOP)/lib -lwais $socketlib -lm $embed_ldopts
|
|
+LDFLAGS = ../lib/libwais.la $socketlib -lm $embed_ldopts
|
|
BIN_EXP = $installbin
|
|
PRIVLIB = $installprivlib
|
|
USRINC = $usrinc
|
|
@@ -112,10 +112,10 @@
|
|
waissearch: waissearch.o $(OBJ1)
|
|
$(RM) $@
|
|
if test -f $@; then $(MV) $@ $@~; else exit 0; fi
|
|
- $(CC) -o $@ waissearch.o $(OBJ1) $(JLDFLAGS) $(LIBS)
|
|
+ $(LIBTOOL) --mode=link $(CC) -o $@ waissearch.o $(OBJ1) $(JLDFLAGS) $(LIBS)
|
|
|
|
install:: waissearch
|
|
- $(INSTALL) -c -s -m 555 waissearch $(BIN_EXP)
|
|
+ $(LIBTOOL) --mode=install $(INSTALL) -c -s -m 555 waissearch $(BIN_EXP)
|
|
|
|
deinstall::
|
|
$(RM) $(BIN_EXP)/waissearch
|
|
@@ -128,10 +128,10 @@
|
|
waisq: waisq.o $(OBJS)
|
|
$(RM) $@
|
|
if test -f $@; then $(MV) $@ $@~; else exit 0; fi
|
|
- $(CC) -o $@ waisq.o $(OBJS) $(JLDFLAGS) $(LIBS)
|
|
+ $(LIBTOOL) --mode=link $(CC) -o $@ waisq.o $(OBJS) $(JLDFLAGS) $(LIBS)
|
|
|
|
install:: waisq
|
|
- $(INSTALL) -c -s -m 555 waisq $(BIN_EXP)
|
|
+ $(LIBTOOL) --mode=install $(INSTALL) -c -s -m 555 waisq $(BIN_EXP)
|
|
|
|
deinstall::
|
|
$(RM) $(BIN_EXP)/waisq
|
|
@@ -144,10 +144,10 @@
|
|
swais: swais.o $(OBJS)
|
|
$(RM) $@
|
|
if test -f $@; then $(MV) $@ $@~; else exit 0; fi
|
|
- $(CC) -o $@ swais.o $(OBJS) $(JLDFLAGS) $(LIBS)
|
|
+ $(LIBTOOL) --mode=link $(CC) -o $@ swais.o $(OBJS) $(JLDFLAGS) $(LIBS)
|
|
|
|
install:: swais
|
|
- $(INSTALL) -c -s -m 555 swais $(BIN_EXP)
|
|
+ $(LIBTOOL) --mode=install $(INSTALL) -c -s -m 555 swais $(BIN_EXP)
|
|
|
|
deinstall::
|
|
$(RM) $(BIN_EXP)/swais
|