b6c92f8952
V3.2.0 2003/11/28 ================= -Updated source to compile with recent gcc compilers -Pausing mp3/wav/ogg playback releases the sound device -Better mp3 integrity checks. Songs that didn't previously play (or only partly), should now play fine (as in, the bits that are valid) -Fixed a bug that would hang mp3blaster if you'd be in a dir that was deleted meanwhile. -bugfix that could crash mp3blaster after a request to quit (..) -bugfix that failed to redraw screen correctly after operations that required input (such as convert to wav, enter group name, ..) -fixed a bug that could crash mp3blaster on opening oggs when sound device was busy. -Check if the playlist directory actually exists before trying to write a playlist -Added '--repeat/-R' command line option -Applied LIRC support patch from Olgierd Pieczul . Thanks a lot!
321 lines
8.5 KiB
Text
321 lines
8.5 KiB
Text
$NetBSD: patch-aa,v 1.4 2003/12/03 12:31:36 cube Exp $
|
|
|
|
--- getopt/Makefile.in.orig 2003-11-29 15:26:17.000000000 +0100
|
|
+++ getopt/Makefile.in
|
|
@@ -0,0 +1,316 @@
|
|
+# Makefile.in generated automatically by automake 1.4-p6 from Makefile.am
|
|
+
|
|
+# Copyright (C) 1994, 1995-8, 1999, 2001 Free Software Foundation, Inc.
|
|
+# This Makefile.in is free software; the Free Software Foundation
|
|
+# gives unlimited permission to copy and/or distribute it,
|
|
+# with or without modifications, as long as this notice is preserved.
|
|
+
|
|
+# This program is distributed in the hope that it will be useful,
|
|
+# but WITHOUT ANY WARRANTY, to the extent permitted by law; without
|
|
+# even the implied warranty of MERCHANTABILITY or FITNESS FOR A
|
|
+# PARTICULAR PURPOSE.
|
|
+
|
|
+
|
|
+SHELL = @SHELL@
|
|
+
|
|
+srcdir = @srcdir@
|
|
+top_srcdir = @top_srcdir@
|
|
+VPATH = @srcdir@
|
|
+prefix = @prefix@
|
|
+exec_prefix = @exec_prefix@
|
|
+
|
|
+bindir = @bindir@
|
|
+sbindir = @sbindir@
|
|
+libexecdir = @libexecdir@
|
|
+datadir = @datadir@
|
|
+sysconfdir = @sysconfdir@
|
|
+sharedstatedir = @sharedstatedir@
|
|
+localstatedir = @localstatedir@
|
|
+libdir = @libdir@
|
|
+infodir = @infodir@
|
|
+mandir = @mandir@
|
|
+includedir = @includedir@
|
|
+oldincludedir = /usr/include
|
|
+
|
|
+DESTDIR =
|
|
+
|
|
+pkgdatadir = $(datadir)/@PACKAGE@
|
|
+pkglibdir = $(libdir)/@PACKAGE@
|
|
+pkgincludedir = $(includedir)/@PACKAGE@
|
|
+
|
|
+top_builddir = ..
|
|
+
|
|
+ACLOCAL = @ACLOCAL@
|
|
+AUTOCONF = @AUTOCONF@
|
|
+AUTOMAKE = @AUTOMAKE@
|
|
+AUTOHEADER = @AUTOHEADER@
|
|
+
|
|
+INSTALL = @INSTALL@
|
|
+INSTALL_PROGRAM = @INSTALL_PROGRAM@ $(AM_INSTALL_PROGRAM_FLAGS)
|
|
+INSTALL_DATA = @INSTALL_DATA@
|
|
+INSTALL_SCRIPT = @INSTALL_SCRIPT@
|
|
+transform = @program_transform_name@
|
|
+
|
|
+NORMAL_INSTALL = :
|
|
+PRE_INSTALL = :
|
|
+POST_INSTALL = :
|
|
+NORMAL_UNINSTALL = :
|
|
+PRE_UNINSTALL = :
|
|
+POST_UNINSTALL = :
|
|
+host_alias = @host_alias@
|
|
+host_triplet = @host@
|
|
+CC = @CC@
|
|
+CXX = @CXX@
|
|
+HAVE_LIB = @HAVE_LIB@
|
|
+LIB = @LIB@
|
|
+LIBGETOPT = @LIBGETOPT@
|
|
+LIBMPEGSOUND = @LIBMPEGSOUND@
|
|
+LIBMYSQL = @LIBMYSQL@
|
|
+LIBNMIXER = @LIBNMIXER@
|
|
+LIRC_LIBS = @LIRC_LIBS@
|
|
+LN_S = @LN_S@
|
|
+LTLIB = @LTLIB@
|
|
+MAKEINFO = @MAKEINFO@
|
|
+MP3B_MODULES = @MP3B_MODULES@
|
|
+NAS_CFLAGS = @NAS_CFLAGS@
|
|
+NAS_LIBS = @NAS_LIBS@
|
|
+NCURSES_LIBS = @NCURSES_LIBS@
|
|
+OGG_LIBS = @OGG_LIBS@
|
|
+PACKAGE = @PACKAGE@
|
|
+RANLIB = @RANLIB@
|
|
+SID_LIBS = @SID_LIBS@
|
|
+SRCDIRS = @SRCDIRS@
|
|
+VERSION = @VERSION@
|
|
+
|
|
+noinst_LIBRARIES = libgetopt.a
|
|
+libgetopt_a_SOURCES = gnugetopt.h getopt.c getopt1.c
|
|
+mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
|
|
+CONFIG_HEADER = ../config.h
|
|
+CONFIG_CLEAN_FILES =
|
|
+LIBRARIES = $(noinst_LIBRARIES)
|
|
+
|
|
+
|
|
+DEFS = @DEFS@ -I. -I$(srcdir) -I..
|
|
+CPPFLAGS = @CPPFLAGS@
|
|
+LDFLAGS = @LDFLAGS@
|
|
+LIBS = @LIBS@
|
|
+X_CFLAGS = @X_CFLAGS@
|
|
+X_LIBS = @X_LIBS@
|
|
+X_EXTRA_LIBS = @X_EXTRA_LIBS@
|
|
+X_PRE_LIBS = @X_PRE_LIBS@
|
|
+libgetopt_a_LIBADD =
|
|
+libgetopt_a_OBJECTS = getopt.o getopt1.o
|
|
+AR = ar
|
|
+CFLAGS = @CFLAGS@
|
|
+COMPILE = $(CC) $(DEFS) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)
|
|
+CCLD = $(CC)
|
|
+LINK = $(CCLD) $(AM_CFLAGS) $(CFLAGS) $(LDFLAGS) -o $@
|
|
+DIST_COMMON = Makefile.am Makefile.in
|
|
+
|
|
+
|
|
+DISTFILES = $(DIST_COMMON) $(SOURCES) $(HEADERS) $(TEXINFOS) $(EXTRA_DIST)
|
|
+
|
|
+TAR = tar
|
|
+GZIP_ENV = --best
|
|
+DEP_FILES = .deps/getopt.P .deps/getopt1.P
|
|
+SOURCES = $(libgetopt_a_SOURCES)
|
|
+OBJECTS = $(libgetopt_a_OBJECTS)
|
|
+
|
|
+all: all-redirect
|
|
+.SUFFIXES:
|
|
+.SUFFIXES: .S .c .o .s
|
|
+$(srcdir)/Makefile.in: Makefile.am $(top_srcdir)/configure.in $(ACLOCAL_M4)
|
|
+ cd $(top_srcdir) && $(AUTOMAKE) --gnu getopt/Makefile
|
|
+
|
|
+Makefile: $(srcdir)/Makefile.in $(top_builddir)/config.status $(BUILT_SOURCES)
|
|
+ cd $(top_builddir) \
|
|
+ && CONFIG_FILES=$(subdir)/$@ CONFIG_HEADERS= $(SHELL) ./config.status
|
|
+
|
|
+
|
|
+mostlyclean-noinstLIBRARIES:
|
|
+
|
|
+clean-noinstLIBRARIES:
|
|
+ -test -z "$(noinst_LIBRARIES)" || rm -f $(noinst_LIBRARIES)
|
|
+
|
|
+distclean-noinstLIBRARIES:
|
|
+
|
|
+maintainer-clean-noinstLIBRARIES:
|
|
+
|
|
+.s.o:
|
|
+ $(COMPILE) -c $<
|
|
+
|
|
+.S.o:
|
|
+ $(COMPILE) -c $<
|
|
+
|
|
+mostlyclean-compile:
|
|
+ -rm -f *.o core *.core
|
|
+
|
|
+clean-compile:
|
|
+
|
|
+distclean-compile:
|
|
+ -rm -f *.tab.c
|
|
+
|
|
+maintainer-clean-compile:
|
|
+
|
|
+libgetopt.a: $(libgetopt_a_OBJECTS) $(libgetopt_a_DEPENDENCIES)
|
|
+ -rm -f libgetopt.a
|
|
+ $(AR) cru libgetopt.a $(libgetopt_a_OBJECTS) $(libgetopt_a_LIBADD)
|
|
+ $(RANLIB) libgetopt.a
|
|
+
|
|
+tags: TAGS
|
|
+
|
|
+ID: $(HEADERS) $(SOURCES) $(LISP)
|
|
+ list='$(SOURCES) $(HEADERS)'; \
|
|
+ unique=`for i in $$list; do echo $$i; done | \
|
|
+ awk ' { files[$$0] = 1; } \
|
|
+ END { for (i in files) print i; }'`; \
|
|
+ here=`pwd` && cd $(srcdir) \
|
|
+ && mkid -f$$here/ID $$unique $(LISP)
|
|
+
|
|
+TAGS: $(HEADERS) $(SOURCES) $(TAGS_DEPENDENCIES) $(LISP)
|
|
+ tags=; \
|
|
+ here=`pwd`; \
|
|
+ list='$(SOURCES) $(HEADERS)'; \
|
|
+ unique=`for i in $$list; do echo $$i; done | \
|
|
+ awk ' { files[$$0] = 1; } \
|
|
+ END { for (i in files) print i; }'`; \
|
|
+ test -z "$(ETAGS_ARGS)$$unique$(LISP)$$tags" \
|
|
+ || (cd $(srcdir) && etags $(ETAGS_ARGS) $$tags $$unique $(LISP) -o $$here/TAGS)
|
|
+
|
|
+mostlyclean-tags:
|
|
+
|
|
+clean-tags:
|
|
+
|
|
+distclean-tags:
|
|
+ -rm -f TAGS ID
|
|
+
|
|
+maintainer-clean-tags:
|
|
+
|
|
+distdir = $(top_builddir)/$(PACKAGE)-$(VERSION)/$(subdir)
|
|
+
|
|
+subdir = getopt
|
|
+
|
|
+distdir: $(DISTFILES)
|
|
+ here=`cd $(top_builddir) && pwd`; \
|
|
+ top_distdir=`cd $(top_distdir) && pwd`; \
|
|
+ distdir=`cd $(distdir) && pwd`; \
|
|
+ cd $(top_srcdir) \
|
|
+ && $(AUTOMAKE) --include-deps --build-dir=$$here --srcdir-name=$(top_srcdir) --output-dir=$$top_distdir --gnu getopt/Makefile
|
|
+ @for file in $(DISTFILES); do \
|
|
+ d=$(srcdir); \
|
|
+ if test -d $$d/$$file; then \
|
|
+ cp -pr $$d/$$file $(distdir)/$$file; \
|
|
+ else \
|
|
+ test -f $(distdir)/$$file \
|
|
+ || ln $$d/$$file $(distdir)/$$file 2> /dev/null \
|
|
+ || cp -p $$d/$$file $(distdir)/$$file || :; \
|
|
+ fi; \
|
|
+ done
|
|
+
|
|
+DEPS_MAGIC := $(shell mkdir .deps > /dev/null 2>&1 || :)
|
|
+
|
|
+-include $(DEP_FILES)
|
|
+
|
|
+mostlyclean-depend:
|
|
+
|
|
+clean-depend:
|
|
+
|
|
+distclean-depend:
|
|
+ -rm -rf .deps
|
|
+
|
|
+maintainer-clean-depend:
|
|
+
|
|
+%.o: %.c
|
|
+ @echo '$(COMPILE) -c $<'; \
|
|
+ $(COMPILE) -Wp,-MD,.deps/$(*F).pp -c $<
|
|
+ @-cp .deps/$(*F).pp .deps/$(*F).P; \
|
|
+ tr ' ' '\012' < .deps/$(*F).pp \
|
|
+ | sed -e 's/^\\$$//' -e '/^$$/ d' -e '/:$$/ d' -e 's/$$/ :/' \
|
|
+ >> .deps/$(*F).P; \
|
|
+ rm .deps/$(*F).pp
|
|
+
|
|
+%.lo: %.c
|
|
+ @echo '$(LTCOMPILE) -c $<'; \
|
|
+ $(LTCOMPILE) -Wp,-MD,.deps/$(*F).pp -c $<
|
|
+ @-sed -e 's/^\([^:]*\)\.o[ ]*:/\1.lo \1.o :/' \
|
|
+ < .deps/$(*F).pp > .deps/$(*F).P; \
|
|
+ tr ' ' '\012' < .deps/$(*F).pp \
|
|
+ | sed -e 's/^\\$$//' -e '/^$$/ d' -e '/:$$/ d' -e 's/$$/ :/' \
|
|
+ >> .deps/$(*F).P; \
|
|
+ rm -f .deps/$(*F).pp
|
|
+info-am:
|
|
+info: info-am
|
|
+dvi-am:
|
|
+dvi: dvi-am
|
|
+check-am: all-am
|
|
+check: check-am
|
|
+installcheck-am:
|
|
+installcheck: installcheck-am
|
|
+install-exec-am:
|
|
+install-exec: install-exec-am
|
|
+
|
|
+install-data-am:
|
|
+install-data: install-data-am
|
|
+
|
|
+install-am: all-am
|
|
+ @$(MAKE) $(AM_MAKEFLAGS) install-exec-am install-data-am
|
|
+install: install-am
|
|
+uninstall-am:
|
|
+uninstall: uninstall-am
|
|
+all-am: Makefile $(LIBRARIES)
|
|
+all-redirect: all-am
|
|
+install-strip:
|
|
+ $(MAKE) $(AM_MAKEFLAGS) AM_INSTALL_PROGRAM_FLAGS=-s install
|
|
+installdirs:
|
|
+
|
|
+
|
|
+mostlyclean-generic:
|
|
+
|
|
+clean-generic:
|
|
+
|
|
+distclean-generic:
|
|
+ -rm -f Makefile $(CONFIG_CLEAN_FILES)
|
|
+ -rm -f config.cache config.log stamp-h stamp-h[0-9]*
|
|
+
|
|
+maintainer-clean-generic:
|
|
+mostlyclean-am: mostlyclean-noinstLIBRARIES mostlyclean-compile \
|
|
+ mostlyclean-tags mostlyclean-depend mostlyclean-generic
|
|
+
|
|
+mostlyclean: mostlyclean-am
|
|
+
|
|
+clean-am: clean-noinstLIBRARIES clean-compile clean-tags clean-depend \
|
|
+ clean-generic mostlyclean-am
|
|
+
|
|
+clean: clean-am
|
|
+
|
|
+distclean-am: distclean-noinstLIBRARIES distclean-compile \
|
|
+ distclean-tags distclean-depend distclean-generic \
|
|
+ clean-am
|
|
+
|
|
+distclean: distclean-am
|
|
+
|
|
+maintainer-clean-am: maintainer-clean-noinstLIBRARIES \
|
|
+ maintainer-clean-compile maintainer-clean-tags \
|
|
+ maintainer-clean-depend maintainer-clean-generic \
|
|
+ distclean-am
|
|
+ @echo "This command is intended for maintainers to use;"
|
|
+ @echo "it deletes files that may require special tools to rebuild."
|
|
+
|
|
+maintainer-clean: maintainer-clean-am
|
|
+
|
|
+.PHONY: mostlyclean-noinstLIBRARIES distclean-noinstLIBRARIES \
|
|
+clean-noinstLIBRARIES maintainer-clean-noinstLIBRARIES \
|
|
+mostlyclean-compile distclean-compile clean-compile \
|
|
+maintainer-clean-compile tags mostlyclean-tags distclean-tags \
|
|
+clean-tags maintainer-clean-tags distdir mostlyclean-depend \
|
|
+distclean-depend clean-depend maintainer-clean-depend info-am info \
|
|
+dvi-am dvi check check-am installcheck-am installcheck install-exec-am \
|
|
+install-exec install-data-am install-data install-am install \
|
|
+uninstall-am uninstall all-redirect all-am all installdirs \
|
|
+mostlyclean-generic distclean-generic clean-generic \
|
|
+maintainer-clean-generic clean mostlyclean distclean maintainer-clean
|
|
+
|
|
+
|
|
+# Tell versions [3.59,3.63) of GNU make to not export all variables.
|
|
+# Otherwise a system limit (for SysV at least) may be exceeded.
|
|
+.NOEXPORT:
|