* Fix compile bug with some compilers on 64 bit. Changes 1.16.33: * Build: Fix prototype/definition mismatch in libwww.cpp with some compilers (e.g. Solaris). * Build: Fix linking of xml-rpc-api2cpp with some linkers (e.g. Solaris). Changes 1.16.32: * Windows Abyss server: properly handle wait for connection. Changes 1.16.31: * CGI XML-RPC server accepts (ignores) parameters after "text/xml" in Content-type header from client.
13 lines
423 B
Text
13 lines
423 B
Text
$NetBSD: patch-ak,v 1.2 2011/04/06 07:45:48 adam Exp $
|
|
|
|
--- tools/xml-rpc-api2cpp/Makefile.orig 2011-03-25 16:58:35.000000000 +0000
|
|
+++ tools/xml-rpc-api2cpp/Makefile
|
|
@@ -44,7 +44,7 @@ xml-rpc-api2cpp: \
|
|
$(LIBXMLRPC) \
|
|
$(LIBXMLRPC_XML) \
|
|
$(LIBXMLRPC_UTIL)
|
|
- $(CXXLD) -o $@ $(LDFLAGS) $(OBJECTS) $(LDLIBS)
|
|
+ libtool --mode=link $(CXXLD) -o $@ $(LDFLAGS) $(OBJECTS) $(LDLIBS)
|
|
|
|
%.o:%.cpp
|
|
$(CXX) -c $(CXXFLAGS) $<
|