pkgsrc/graphics/hugin/patches/patch-CMakeLists.txt
adam d7b2208231 The version 2017.0 is mainly a bug fix release. The biggest fixes regard:
* Several fixes for working with HDR images (display in GUI, photometric optimizer, handling of under/over exposured pixels in merging code).
* Fixes handling of masks in cpfind when images needs remapping for cp finding.
* Sometimes unsaved changes were disregarded without asking the user (e.g. when loading a project via the recently used projects list). Unsaved changes should now always require user confirmation.

Besides the bug fixes some smaller improvements have been implemented.
* Optimizer tabs uses now checkboxes instead of bold underlined font for marking of variables to be optimized.
* Use wxWidgets help windows instead of default browser (Linux&Mac only, this provides table of content, index and full text search in help files).
* Added special assistant variant for single image projects.
* Display of final panorama dimensions on stitcher tab.
* Extended the user defined output sequences:
  - The shipped user defined output sequences are exposed in the GUI as own sub-menu.
  - Added some more user defined output sequences (layered TIFF, cube faces).
  - Added new placeholder %sourceimage% to user defined output sequence.
2017-07-03 20:48:03 +00:00

34 lines
1.1 KiB
Text

$NetBSD: patch-CMakeLists.txt,v 1.4 2017/07/03 20:48:03 adam Exp $
Do not make an application bundle on OS X.
--- CMakeLists.txt.orig 2017-05-15 15:05:31.000000000 +0000
+++ CMakeLists.txt
@@ -2,10 +2,6 @@
# require at least cmake 3.1
cmake_minimum_required(VERSION 3.1.0 FATAL_ERROR )
-# prevent in-tree building
-if("${CMAKE_SOURCE_DIR}" STREQUAL "${CMAKE_BINARY_DIR}")
- message(FATAL_ERROR "In-source builds are not allowed.")
-endif()
if(COMMAND cmake_policy)
cmake_policy(SET CMP0003 NEW)
@@ -570,16 +566,6 @@ IF (APPLE)
ENDIF (NOT MAC_SELF_CONTAINED_BUNDLE)
ENDIF (APPLE)
-IF (${HUGIN_SHARED} AND UNIX AND NOT APPLE)
- SET(CMAKE_INSTALL_RPATH "${CMAKE_INSTALL_PREFIX}/${LIBDIR}/hugin")
- SET(HUGIN_LIBS_PRIVATE_DIR "1" CACHE INTERNAL "Store internal
- libraries in private subdirectory" )
-ELSE (${HUGIN_SHARED} AND UNIX AND NOT APPLE)
- # On OS X files are moved around after make install, do not try to use
- # rpath or CMAKE_INSTALL_NAME_DIR
- SET(HUGIN_LIBS_PRIVATE_DIR "0" CACHE INTERNAL "Store internal
- libraries in private subdirectory" )
-ENDIF (${HUGIN_SHARED} AND UNIX AND NOT APPLE)
IF (UNIX)
IF (${HUGIN_SHARED})