pkgsrc/security/stunnel/patches/patch-ac
ryoon fe09ce1470 Update to 4.46
Changelog:
Version 4.46, 2011.11.04, urgency: LOW:
* New features
  - Added Unix socket support (e.g. "connect = /var/run/stunnel/socket").
  - Added "verify = 4" mode to ignore CA chain and only verify peer certificate.
  - Removed the limit of 16 IP addresses for a single 'connect' option.
  - Removed the limit of 256 stunnel.conf sections in PTHREAD threading model.
    It is still not possible have more than 63 sections on WIN32 platform.
    http://msdn.microsoft.com/en-us/library/windows/desktop/ms740141(v=vs.85).aspx
* Optimizations
  - Reduced per-connection memory usage.
  - Performed a major refactoring of internal data structures.  Extensive
    internal testing was performed, but some regression bugs are expected.
* Bugfixes
  - Fixed WIN32 compilation with Mingw32.
  - Fixed non-blocking API emulation layer in UCONTEXT threading model.
  - Fixed signal handling in UCONTEXT threading model.
2011-11-10 21:01:39 +00:00

15 lines
534 B
Text

$NetBSD: patch-ac,v 1.15 2011/11/10 21:01:39 ryoon Exp $
Change pid file location.
--- src/Makefile.in.orig 2011-11-04 20:24:15.000000000 +0000
+++ src/Makefile.in
@@ -271,7 +271,7 @@ libstunnel_la_LDFLAGS = -avoid-version
# Additional preprocesor definitions
stunnel_CPPFLAGS = -I/usr/kerberos/include -I$(SSLDIR)/include \
- -DLIBDIR='"$(pkglibdir)"' -DCONFDIR='"$(sysconfdir)/stunnel"' \
+ -DLIBDIR='"$(pkglibdir)"' -DCONFDIR='"$(sysconfdir)"' \
-DPIDFILE='"$(localstatedir)/run/stunnel/stunnel.pid"'
# Win32 executable