pkgsrc/lang/STk/patches/patch-ad
jtb ef091fdc86 Update to 4.0.1.
Notable changes include:

* Dynamic loading now works on NetBSD ELF systems.
* Integration of SRFI-9 (records)
* Accepts mailto: links in the browser
* <Scroll-Frame>, <Toolbar> STklos classes.
* Integration of some finals SRFI (0, 2, 6, 8)
* define-syntax (but not let-syntax and let-syntax*)
* New License Policy (request for commercial apps no more needed).
* A console mode (which is used by default on Windows, but can
  be used with the -console option on Unix)
* A new editor with Scheme fontification and indentation
* New kind of ports: virtual ports
* All the code dealing with files has been rewritten.
* Tk level is 8.0.3 (the latest stable Tk release)
* New STklos Classes:
	+ <Hierarchy-tree> and <Hierarchy-item> to draw
	  hierarchy such as files/directories, class/metaclasses ...
	+ <Notepad> to define ... notepads
	+ <Scheme-text> which extends <Text> to "font-lockify"
	  Scheme buffers
* Method and generic function editor
* A class browser (type "(class-browser)" to access it)
* some new manual pages
* Base64 Encoding/Decoding extension
* Locale extension to treat strings and character using locale information
* Better installation scripts (+ some corrections)
* Lot of bug fixes.
2003-05-10 00:26:33 +00:00

43 lines
1.1 KiB
Text

$NetBSD: patch-ad,v 1.3 2003/05/10 00:26:34 jtb Exp $
--- configure.in.orig
+++ configure.in
@@ -16,7 +16,10 @@
# determine the kind of the machine which is running this script
os=`uname -s`
version=`uname -r`
-machine=`uname -m`
+# NetBSD:
+# allow sharing between different arch's which use the same processor
+# Ie, use 'm68k' instead of 'amiga', 'mac68k', 'hp300', etc.
+machine=`uname -p`
case $os in
Linux*)
@@ -113,7 +116,7 @@
ULTRIX*) OS=ULTRIX;;
HP*) OS=HPUX; DFLGS="$DFLGS -Dhpux";;
Linux*) OS=LINUX;;
- NetBSD-1*) OS=NETBSD1;;
+ NetBSD*) OS=NETBSD;;
FreeBSD*) OS=FREEBSD;;
IRIX-5*) OS=IRIX5;;
IRIX*-6*) OS=IRIX5;;
@@ -443,11 +446,12 @@
SH_LDFLAGS="-shared -o"
SH_LOADER="ld"
SH_SUFFIX='so' ;;
- NETBSD1)
- SH_CCFLAGS="-fpic"
- SH_LDFLAGS="-Bshareable -o"
- SH_LOADER="ld"
- SH_SUFFIX='so';;
+ NETBSD)
+ SH_CCFLAGS="-fPIC"
+ SH_LDFLAGS="-shared -o"
+ SH_LOADER="cc"
+ SH_SUFFIX="so"
+ STKLDFLAGS="-Wl,-E";;
HPUX)
SH_CCFLAGS="+Z"
SH_LDFLAGS="-b -o"