cdcc298e59
Changelog: The following changes have been made between John 1.7.3 and 1.7.3.1: * Corrected the x86 assembly files for building on Mac OS X. * Merged in some generic changes from JtR Pro. The following changes have been made between John 1.7.2 and 1.7.3: * Two Blowfish-based crypt(3) hashes may now be computed in parallel for much better performance on modern multi-issue CPUs with a sufficient number of registers (e.g., x86-64). * Bitslice DES assembly code for x86-64 has been converted to use instruction pointer relative addressing (needed for Mac OS X support). * New make targets: macosx-universal, macosx-x86-64, solaris-x86-64-cc, solaris-x86-64-gcc, solaris-x86-sse2-cc, solaris-x86-sse2-gcc, solaris-x86-mmx-cc, solaris-x86-mmx-gcc, solaris-x86-any-cc, linux-ia64; other changes to the Makefile. * Minor bug fixes. * "DumbForce" and "KnownForce" external mode samples have been added to the default john.conf.
20 lines
456 B
Text
20 lines
456 B
Text
$NetBSD: patch-aa,v 1.6 2009/08/06 19:14:52 zafer Exp $
|
|
|
|
--- src/Makefile.orig 2009-08-06 20:58:11.000000000 +0200
|
|
+++ src/Makefile
|
|
@@ -15,11 +15,11 @@ SED = sed
|
|
PERL = perl
|
|
NULL = /dev/null
|
|
CPPFLAGS = -E
|
|
-CFLAGS = -c -Wall -O2 -fomit-frame-pointer
|
|
+CFLAGS = -c
|
|
ASFLAGS = -c
|
|
-LDFLAGS = -s
|
|
-OPT_NORMAL = -funroll-loops
|
|
-OPT_INLINE = -finline-functions
|
|
+LDFLAGS += -s
|
|
+OPT_NORMAL =
|
|
+OPT_INLINE =
|
|
|
|
JOHN_OBJS_MINIMAL = \
|
|
DES_fmt.o DES_std.o DES_bs.o \
|