pkgsrc/print/cups-base/patches/patch-conf_Makefile
triaxx 4801744ae8 libcups: fix build failure on FreeBSD
pkgsrc changes:
---------------
  * Add conditional inclusion for FreeBSD.
  * Apply some changes to appease pkglint.
  * Bump revision.
2020-05-26 08:36:55 +00:00

29 lines
987 B
Text

$NetBSD: patch-conf_Makefile,v 1.2 2020/05/26 08:36:56 triaxx Exp $
Don't install the config files (leave it up to pkgsrc).
--- conf/Makefile.orig 2015-02-27 12:30:26.000000000 +0000
+++ conf/Makefile
@@ -64,22 +64,8 @@ install: all install-data install-header
#
install-data:
- for file in $(KEEP); do \
- if test -r $(SERVERROOT)/$$file ; then \
- $(INSTALL_CONFIG) -g $(CUPS_GROUP) $$file $(SERVERROOT)/$$file.N ; \
- else \
- $(INSTALL_CONFIG) -g $(CUPS_GROUP) $$file $(SERVERROOT) ; \
- fi ; \
- $(INSTALL_CONFIG) -g $(CUPS_GROUP) $$file $(SERVERROOT)/$$file.default; \
- done
$(INSTALL_DIR) -m 755 $(DATADIR)/mime
for file in $(REPLACE); do \
- if test -r $(DATADIR)/mime/$$file ; then \
- $(MV) $(DATADIR)/mime/$$file $(DATADIR)/mime/$$file.O ; \
- fi ; \
- if test -r $(SERVERROOT)/$$file ; then \
- $(MV) $(SERVERROOT)/$$file $(DATADIR)/mime/$$file.O ; \
- fi ; \
$(INSTALL_DATA) $$file $(DATADIR)/mime ; \
done
-if test x$(PAMDIR) != x; then \