Changes: kdelibs: * https authentication through proxy fixed. * KZip failed for some .zip archives. * Fixed a bug in socket code that made KDEPrint crash. * kspell: Support for Hebrew spell checking using hspell (requires hspell 0.5). kdebase: * kwin: Alt+Tab works while drag'n'drop (unless the application also grabs keyboard). * kio_smtp: Doesn't eat 100% CPU when connection breaks and fixed a confusing error message when AUTH failed ("Unknown Command" vs. "Authorization failed") * kscreensaver: Fixed issue where kdesktop_lock would stay running indefinitely in the background if it could not grab the keyboard/mouse, preventing the screen from being locked manually. * kscreensaver: Screensavers are now stopped when asking for the password [#56803] * kio_smb: Several bugfixes for the smbro-ioslave. * kdesktop: fixed minicli layout problem with Qt 3.1.2 * kdm: fixed incorrect user window width with Qt 3.1.2 * Konqueror: Create DCOP interface for mainwindow when object begins to exist. * Konqueror: Fixed tab open delays when it can't reach website. * Konsole: Don't flicker when selecting entire lines. * Konsole: Crash, selection and sort fixes in schema and session editors. * Konsole: Fixed mouse-wheel in mouse mode. * Konsole: Allow programs to resize windows if enabled. * Konsole: Keep output steady when triple-click selecting. * Konsole: Added "Print" menu command. * kicker: Fixed kasbar only drawing last icon from a group.
66 lines
2.5 KiB
Text
66 lines
2.5 KiB
Text
$NetBSD: patch-cs,v 1.5 2003/05/22 02:42:50 markd Exp $
|
|
|
|
--- konsole/konsole/Makefile.am.orig Wed May 7 23:44:16 2003
|
|
+++ konsole/konsole/Makefile.am
|
|
@@ -12,7 +12,7 @@ INCLUDES = -I. $(all_includes)
|
|
|
|
# you can add here more. This one gets installed
|
|
bin_PROGRAMS = konsole konsole_grantpty kwrited #kcmkonsole
|
|
-lib_LTLIBRARIES = kwrited.la konsole.la
|
|
+lib_LTLIBRARIES = libkwrited_main.la kwrited.la libkonsole_main.la konsole.la
|
|
|
|
# libkonsolepart is a part, but konsole.la links directly to it, so we can't
|
|
# install it under kde_module
|
|
@@ -34,26 +34,34 @@ libkonsolepart_la_LDFLAGS = $(all_librar
|
|
libkonsolepart_la_LIBADD = $(LIBUTIL) $(XTESTLIB) $(LIB_KPARTS)
|
|
|
|
# kwrited kdeinit module
|
|
-kwrited_la_SOURCES = kwrited.cpp
|
|
-kwrited_la_LIBADD = libkonsolepart.la
|
|
+libkwrited_main_la_SOURCES = kwrited.cpp
|
|
+libkwrited_main_la_LIBADD = libkonsolepart.la
|
|
+libkwrited_main_la_LDFLAGS = $(all_libraries)
|
|
+
|
|
+kwrited_la_SOURCES = kwrited_main.cpp
|
|
+kwrited_la_LIBADD = libkwrited_main.la
|
|
kwrited_la_LDFLAGS = $(all_libraries) -module -avoid-version
|
|
|
|
# kwrited executable
|
|
-kwrited_SOURCES = dummy.cpp
|
|
-kwrited_LDADD = kwrited.la
|
|
+kwrited_SOURCES = kwrited_main.cpp
|
|
+kwrited_LDADD = libkwrited_main.la
|
|
kwrited_LDFLAGS = $(all_libraries) $(KDE_RPATH)
|
|
|
|
|
|
# konsole kdeinit module
|
|
-konsole_la_SOURCES = TEPty.cpp BlockArray.cpp main.cpp konsole.cpp schema.cpp session.cpp TEWidget.cpp TEmuVt102.cpp \
|
|
+libkonsole_main_la_SOURCES = TEPty.cpp BlockArray.cpp main.cpp konsole.cpp schema.cpp session.cpp TEWidget.cpp TEmuVt102.cpp \
|
|
TEScreen.cpp TEmulation.cpp TEHistory.cpp keytrans.cpp konsoleiface.skel sessioniface.skel \
|
|
konsole_wcwidth.cpp konsolebookmarkhandler.cpp konsolebookmarkmenu.cpp konsole_child.cpp
|
|
+libkonsole_main_la_LDFLAGS = $(all_libraries)
|
|
+libkonsole_main_la_LIBADD = $(LIB_KDEPRINT) $(LIBUTIL) $(XTESTLIB)
|
|
+
|
|
+konsole_la_SOURCES = konsole_main.cpp
|
|
konsole_la_LDFLAGS = $(all_libraries) -module -avoid-version
|
|
-konsole_la_LIBADD = $(LIB_KDEPRINT) $(LIBUTIL) $(XTESTLIB)
|
|
+konsole_la_LIBADD = libkonsole_main.la
|
|
|
|
# konsole executable
|
|
-konsole_SOURCES = dummy.cpp
|
|
-konsole_LDADD = konsole.la $(LIB_KDEPRINT)
|
|
+konsole_SOURCES = konsole_main.cpp
|
|
+konsole_LDADD = libkonsole_main.la
|
|
konsole_LDFLAGS = $(all_libraries) $(KDE_RPATH)
|
|
|
|
# kcmkonsole_SOURCES = kcmkonsole.cpp schema.cpp
|
|
@@ -97,9 +105,6 @@ messages: rc.cpp
|
|
$(XGETTEXT) rc.cpp *.cpp -o $(podir)/konsole.pot
|
|
rm -f schemas.cpp
|
|
rm -f tips.cpp
|
|
-
|
|
-dummy.cpp:
|
|
- echo > dummy.cpp
|
|
|
|
# setting up x-application/konsole as a special mimetype
|
|
mimedir = $(kde_mimedir)/application
|