pkgsrc/x11/kdebase3/patches/patch-dj
markd 1ff6ba76b9 Update KDE to 3.1.2.
Changes:

kdelibs:
* https authentication through proxy fixed.
* KZip failed for some .zip archives.
* Fixed a bug in socket code that made KDEPrint crash.
* kspell: Support for Hebrew spell checking using hspell (requires hspell 0.5).

kdebase:
* kwin: Alt+Tab works while drag'n'drop (unless the application also grabs keyboard).
* kio_smtp: Doesn't eat 100% CPU when connection breaks and fixed a confusing error
  message when AUTH failed ("Unknown Command" vs. "Authorization failed")
* kscreensaver: Fixed issue where kdesktop_lock would stay running indefinitely in
  the background if it could not grab the keyboard/mouse, preventing the screen from
  being locked manually.
* kscreensaver: Screensavers are now stopped when asking for the password [#56803]
* kio_smb: Several bugfixes for the smbro-ioslave.
* kdesktop: fixed minicli layout problem with Qt 3.1.2
* kdm: fixed incorrect user window width with Qt 3.1.2
* Konqueror: Create DCOP interface for mainwindow when object begins to exist.
* Konqueror: Fixed tab open delays when it can't reach website.
* Konsole: Don't flicker when selecting entire lines.
* Konsole: Crash, selection and sort fixes in schema and session editors.
* Konsole: Fixed mouse-wheel in mouse mode.
* Konsole: Allow programs to resize windows if enabled.
* Konsole: Keep output steady when triple-click selecting.
* Konsole: Added "Print" menu command.
* kicker: Fixed kasbar only drawing last icon from a group.
2003-05-22 02:42:39 +00:00

31 lines
1 KiB
Text

$NetBSD: patch-dj,v 1.5 2003/05/22 02:42:51 markd Exp $
--- kwin/clients/b2/Makefile.in.orig Tue May 13 23:08:02 2003
+++ kwin/clients/b2/Makefile.in
@@ -428,7 +428,7 @@ SUBDIRS = . config
kde_module_LTLIBRARIES = kwin_b2.la
kwin_b2_la_SOURCES = b2client.cpp
-kwin_b2_la_LIBADD = ../../kwin.la
+kwin_b2_la_LIBADD = ../../libkwin.la
kwin_b2_la_LDFLAGS = $(all_libraries) $(KDE_PLUGIN) -module
#>- METASOURCES = AUTO
@@ -445,7 +445,7 @@ CONFIG_HEADER = $(top_builddir)/config.h
CONFIG_CLEAN_FILES =
LTLIBRARIES = $(kde_module_LTLIBRARIES)
-kwin_b2_la_DEPENDENCIES = ../../kwin.la
+kwin_b2_la_DEPENDENCIES = ../../libkwin.la
am_kwin_b2_la_OBJECTS = b2client.lo
#>- kwin_b2_la_OBJECTS = $(am_kwin_b2_la_OBJECTS)
#>+ 1
@@ -737,7 +737,7 @@ distclean-tags:
-rm -f TAGS ID GTAGS GRTAGS GSYMS GPATH tags
#>- DISTFILES = $(DIST_COMMON) $(DIST_SOURCES) $(TEXINFOS) $(EXTRA_DIST)
#>+ 4
-KDE_DIST=bitmaps.h b2.desktop
+KDE_DIST=b2.desktop bitmaps.h
DISTFILES= $(DIST_COMMON) $(DIST_SOURCES) $(TEXINFOS) $(EXTRA_DIST) $(KDE_DIST)