bc1be86dd4
=============================================================================== Changes in 3.0 =============================================================================== # MPI-3: All MPI-3 features are now implemented and the MPI_VERSION bumped up to 3.0. # OVERALL: Added support for ARM-v7 native atomics # MPE: MPE is now separated out of MPICH and can be downloaded/used as a separate package. # PM/PMI: Upgraded to hwloc-1.6 # Several other minor bug fixes, memory leak fixes, and code cleanup. A full list of changes is available using: svn log -r10344:HEAD https://svn.mcs.anl.gov/repos/mpi/mpich2/tags/release/mpich-3.0 ... or at the following link: https://trac.mcs.anl.gov/projects/mpich2/log/mpich2/tags/release/mpich-3.0?action=follow_copy&rev=HEAD&stop_rev=10344&mode=follow_copy =============================================================================== Changes in 1.5 =============================================================================== # OVERALL: Nemesis now supports an "--enable-yield=..." configure option for better performance/behavior when oversubscribing processes to cores. Some form of this option is enabled by default on Linux, Darwin, and systems that support sched_yield(). # OVERALL: Added support for Intel Many Integrated Core (MIC) architecture: shared memory, TCP/IP, and SCIF based communication. # OVERALL: Added support for IBM BG/Q architecture. Thanks to IBM for the contribution. # MPI-3: const support has been added to mpi.h, although it is disabled by default. It can be enabled on a per-translation unit basis with "#define MPICH2_CONST const". # MPI-3: Added support for MPIX_Type_create_hindexed_block. # MPI-3: The new MPI-3 nonblocking collective functions are now available as "MPIX_" functions (e.g., "MPIX_Ibcast"). # MPI-3: The new MPI-3 neighborhood collective routines are now available as "MPIX_" functions (e.g., "MPIX_Neighbor_allgather"). # MPI-3: The new MPI-3 MPI_Comm_split_type function is now available as an "MPIX_" function. # MPI-3: The new MPI-3 tools interface is now available as "MPIX_T_" functions. This is a beta implementation right now with several limitations, including no support for multithreading. Several performance variables related to CH3's message matching are exposed through this interface. # MPI-3: The new MPI-3 matched probe functionality is supported via the new routines MPIX_Mprobe, MPIX_Improbe, MPIX_Mrecv, and MPIX_Imrecv. # MPI-3: The new MPI-3 nonblocking communicator duplication routine, MPIX_Comm_idup, is now supported. It will only work for single-threaded programs at this time. # MPI-3: MPIX_Comm_reenable_anysource support # MPI-3: Native MPIX_Comm_create_group support (updated version of the prior MPIX_Group_comm_create routine). # MPI-3: MPI_Intercomm_create's internal communication no longer interferes with point-to-point communication, even if point-to-point operations on the parent communicator use the same tag or MPI_ANY_TAG. # MPI-3: Eliminated the possibility of interference between MPI_Intercomm_create and point-to-point messaging operations. # Build system: Completely revamped build system to rely fully on autotools. Parallel builds ("make -j8" and similar) are now supported. # Build system: rename "./maint/updatefiles" --> "./autogen.sh" and "configure.in" --> "configure.ac" # JUMPSHOT: Improvements to Jumpshot to handle thousands of timelines, including performance improvements to slog2 in such cases. # JUMPSHOT: Added navigation support to locate chosen drawable's ends when viewport has been scrolled far from the drawable. # PM/PMI: Added support for memory binding policies. # PM/PMI: Various improvements to the process binding support in Hydra. Several new pre-defined binding options are provided. # PM/PMI: Upgraded to hwloc-1.5 # PM/PMI: Several improvements to PBS support to natively use the PBS launcher. # Several other minor bug fixes, memory leak fixes, and code cleanup. A full list of changes is available using: svn log -r8478:HEAD https://svn.mcs.anl.gov/repos/mpi/mpich2/tags/release/mpich2-1.5 ... or at the following link: https://trac.mcs.anl.gov/projects/mpich2/log/mpich2/tags/release/mpich2-1.5?action=follow_copy&rev=HEAD&stop_rev=8478&mode=follow_copy
57 lines
2.4 KiB
Text
57 lines
2.4 KiB
Text
$NetBSD: patch-Makefile.in,v 1.2 2013/03/17 17:08:51 asau Exp $
|
|
|
|
--- Makefile.in.orig 2012-12-20 21:29:15.000000000 +0100
|
|
+++ Makefile.in 2013-01-24 16:33:41.164187741 +0100
|
|
@@ -5985,6 +5985,7 @@
|
|
srcdir = @srcdir@
|
|
subdirs = @subdirs@
|
|
sysconfdir = @sysconfdir@
|
|
+sysconfexampledir = ${datadir}/examples
|
|
target_alias = @target_alias@
|
|
top_build_prefix = @top_build_prefix@
|
|
top_builddir = @top_builddir@
|
|
@@ -6163,9 +6164,9 @@
|
|
src/mpid/ch3/errnames.txt $(am__append_52) \
|
|
src/mpid/common/sock/errnames.txt $(am__append_87) \
|
|
src/pmi/errnames.txt
|
|
-external_subdirs = src/mpl src/openpa
|
|
+external_subdirs = src/mpl # src/openpa
|
|
# FIXME how/where does external_libs/ldflags get used?
|
|
-external_ldflags = -L$(top_builddir)/src/mpl -L$(top_builddir)/src/openpa/src
|
|
+external_ldflags = -L$(top_builddir)/src/mpl # -L$(top_builddir)/src/openpa/src
|
|
external_libs = -lmpl -lopa $(am__append_12) $(am__append_13)
|
|
|
|
# NOTE on our semi-unconventional usage of DIST_SUBDIRS:
|
|
@@ -23542,25 +23543,25 @@
|
|
dir='$(DESTDIR)$(pkgconfigdir)'; $(am__uninstall_files_from_dir)
|
|
install-sysconfDATA: $(sysconf_DATA)
|
|
@$(NORMAL_INSTALL)
|
|
- @list='$(sysconf_DATA)'; test -n "$(sysconfdir)" || list=; \
|
|
+ @list='$(sysconf_DATA)'; test -n "$(sysconfexampledir)" || list=; \
|
|
if test -n "$$list"; then \
|
|
- echo " $(MKDIR_P) '$(DESTDIR)$(sysconfdir)'"; \
|
|
- $(MKDIR_P) "$(DESTDIR)$(sysconfdir)" || exit 1; \
|
|
+ echo " $(MKDIR_P) '$(DESTDIR)$(sysconfexampledir)'"; \
|
|
+ $(MKDIR_P) "$(DESTDIR)$(sysconfexampledir)" || exit 1; \
|
|
fi; \
|
|
for p in $$list; do \
|
|
if test -f "$$p"; then d=; else d="$(srcdir)/"; fi; \
|
|
echo "$$d$$p"; \
|
|
done | $(am__base_list) | \
|
|
while read files; do \
|
|
- echo " $(INSTALL_DATA) $$files '$(DESTDIR)$(sysconfdir)'"; \
|
|
- $(INSTALL_DATA) $$files "$(DESTDIR)$(sysconfdir)" || exit $$?; \
|
|
+ echo " $(INSTALL_DATA) $$files '$(DESTDIR)$(sysconfexampledir)'"; \
|
|
+ $(INSTALL_DATA) $$files "$(DESTDIR)$(sysconfexampledir)" || exit $$?; \
|
|
done
|
|
|
|
uninstall-sysconfDATA:
|
|
@$(NORMAL_UNINSTALL)
|
|
- @list='$(sysconf_DATA)'; test -n "$(sysconfdir)" || list=; \
|
|
+ @list='$(sysconf_DATA)'; test -n "$(sysconfexampledir)" || list=; \
|
|
files=`for p in $$list; do echo $$p; done | sed -e 's|^.*/||'`; \
|
|
- dir='$(DESTDIR)$(sysconfdir)'; $(am__uninstall_files_from_dir)
|
|
+ dir='$(DESTDIR)$(sysconfexampledir)'; $(am__uninstall_files_from_dir)
|
|
install-includeHEADERS: $(include_HEADERS)
|
|
@$(NORMAL_INSTALL)
|
|
@list='$(include_HEADERS)'; test -n "$(includedir)" || list=; \
|