pkgsrc/graphics/gliv/patches/patch-ab
dholland 94a2330211 Add USE_TOOLS+=gawk and patch accordingly due to heavily nonportable
awk scripts. Fixes PR 33851.

Bump version; the broken scripts were messing up the build without
causing it to overtly fail.
2008-07-21 04:50:40 +00:00

17 lines
697 B
Text

$NetBSD: patch-ab,v 1.3 2008/07/21 04:50:40 dholland Exp $
--- tools/Makefile.in~ 2006-11-18 09:21:13.000000000 -0500
+++ tools/Makefile.in 2008-07-21 00:41:38.000000000 -0400
@@ -491,10 +491,10 @@
all-local: _gliv gliv.ggo
gliv.ggo: gengetopt.awk gliv.options
- awk -f gengetopt.awk < gliv.options > $@
+ gawk -f gengetopt.awk < gliv.options > $@
_gliv: zsh.awk gliv.options gperf2zsh.sh formats.gperf
- (awk -f zsh.awk < gliv.options; ./gperf2zsh.sh formats.gperf) > $@
+ (gawk -f zsh.awk < gliv.options; ./gperf2zsh.sh formats.gperf) > $@
# Tell versions [3.59,3.63) of GNU make to not export all variables.
# Otherwise a system limit (for SysV at least) may be exceeded.
.NOEXPORT: