f999c2f5f4
Fix installation directory of elisp file. Sort PLIST and remove info files entries. Bump PKGREVISION.
72 lines
2.4 KiB
Text
72 lines
2.4 KiB
Text
$NetBSD: patch-ak,v 1.2 2004/03/09 11:24:04 seb Exp $
|
|
|
|
--- ui/Makefile.SH.orig 1999-04-16 09:59:47.000000000 +0000
|
|
+++ ui/Makefile.SH
|
|
@@ -57,7 +57,7 @@ SED = $sed
|
|
|
|
CFLAGS = $ccflags $optimize -I\$(TOP)/lib/ir $mccflags $embed_cflags
|
|
DPFLAGS = -I\$(TOP)/lib/ir $mccflags $embed_cflags
|
|
-LDFLAGS = -L\$(TOP)/lib -lwais $socketlib -lm $embed_ldopts
|
|
+LDFLAGS = ../lib/libwais.la $socketlib -lm $embed_ldopts
|
|
BIN_EXP = $installbin
|
|
PRIVLIB = $installprivlib
|
|
USRINC = $usrinc
|
|
@@ -112,10 +112,10 @@ local_realclean::
|
|
waissearch: waissearch.o $(OBJ1)
|
|
$(RM) $@
|
|
if test -f $@; then $(MV) $@ $@~; else exit 0; fi
|
|
- $(CC) -o $@ waissearch.o $(OBJ1) $(JLDFLAGS) $(LIBS)
|
|
+ $(LIBTOOL) --tag=CC --mode=link $(CC) -o $@ waissearch.o $(OBJ1) $(JLDFLAGS) $(LIBS)
|
|
|
|
install:: waissearch
|
|
- $(INSTALL) -c -s -m 555 waissearch $(BIN_EXP)
|
|
+ $(LIBTOOL) --mode=install $(INSTALL) -c -s -m 555 waissearch $(BIN_EXP)
|
|
|
|
deinstall::
|
|
$(RM) $(BIN_EXP)/waissearch
|
|
@@ -128,10 +128,10 @@ local_realclean::
|
|
waisq: waisq.o $(OBJS)
|
|
$(RM) $@
|
|
if test -f $@; then $(MV) $@ $@~; else exit 0; fi
|
|
- $(CC) -o $@ waisq.o $(OBJS) $(JLDFLAGS) $(LIBS)
|
|
+ $(LIBTOOL) --tag=CC --mode=link $(CC) -o $@ waisq.o $(OBJS) $(JLDFLAGS) $(LIBS)
|
|
|
|
install:: waisq
|
|
- $(INSTALL) -c -s -m 555 waisq $(BIN_EXP)
|
|
+ $(LIBTOOL) --mode=install $(INSTALL) -c -s -m 555 waisq $(BIN_EXP)
|
|
|
|
deinstall::
|
|
$(RM) $(BIN_EXP)/waisq
|
|
@@ -144,10 +144,10 @@ local_realclean::
|
|
swais: swais.o $(OBJS)
|
|
$(RM) $@
|
|
if test -f $@; then $(MV) $@ $@~; else exit 0; fi
|
|
- $(CC) -o $@ swais.o $(OBJS) $(JLDFLAGS) $(LIBS)
|
|
+ $(LIBTOOL) --tag=CC --mode=link $(CC) -o $@ swais.o $(OBJS) $(JLDFLAGS) $(LIBS)
|
|
|
|
install:: swais
|
|
- $(INSTALL) -c -s -m 555 swais $(BIN_EXP)
|
|
+ $(LIBTOOL) --mode=install $(INSTALL) -c -s -m 555 swais $(BIN_EXP)
|
|
|
|
deinstall::
|
|
$(RM) $(BIN_EXP)/swais
|
|
@@ -180,16 +180,13 @@ wais.el: wais.el.raw
|
|
$(SED) -e 's:INSTALLROOT:"$(BIN_EXP)/":g' < wais.el.raw > wais.el;
|
|
|
|
install::
|
|
- @for dir in $(PRIVLIB)/emacs $(PRIVLIB)/emacs/lisp; do \
|
|
- case '${MFLAGS}' in *[i]*) set +e;; esac; \
|
|
- (set -x; test -d $$dir || $(INSTALLDIR) $$dir); \
|
|
- done
|
|
+ $(BSD_INSTALL_DATA_DIR) $(PREFIX)/share/emacs/site-lisp
|
|
|
|
install:: wais.el
|
|
- $(INSTALL) -c -m 444 wais.el $(PRIVLIB)/emacs/lisp
|
|
+ $(BSD_INSTALL_DATA) wais.el $(PREFIX)/share/emacs/site-lisp
|
|
|
|
deinstall::
|
|
- $(RM) $(PRIVLIB)/emacs/lisp/wais.el
|
|
+ $(RM) $(PREFIX)/share/emacs/site-lisp/wais.el
|
|
|
|
local_realclean::
|
|
$(RM) wais.el
|