50f21fdec0
* Bug fixes * New features: - otherlibs/labltk: browser uses menu bars instead of menu buttons Changes 3.09.0: Language features: - Introduction of private row types, for abstracting the row in object and variant types. Type checking: - Polymorphic variants with at most one constructor [< `A of t] are no longer systematically promoted to the exact type [`A of t]. This was more confusing than useful, and created problems with private row types. Native-code compiler (ocamlopt): * Revised implementation of the -pack option (packing of several compilation units into one). The .cmx files that are to be packed with "ocamlopt -pack -o P.cmx" must be compiled with "ocamlopt -for-pack P". In exchange for this additional constraint, ocamlopt -pack is now available on all platforms (no need for binutils). * Fixed wrong evaluation order for arguments to certain inlined functions. * Other (see 'Changes')
32 lines
1.2 KiB
Text
32 lines
1.2 KiB
Text
$NetBSD: patch-aj,v 1.6 2006/01/16 09:41:48 adam Exp $
|
|
|
|
--- byterun/Makefile.orig 2005-11-29 12:57:49.000000000 +0100
|
|
+++ byterun/Makefile
|
|
@@ -16,7 +16,7 @@
|
|
include ../config/Makefile
|
|
|
|
CC=$(BYTECC)
|
|
-CFLAGS=-DCAML_NAME_SPACE -O $(BYTECCCOMPOPTS)
|
|
+CFLAGS+=-DCAML_NAME_SPACE $(BYTECCCOMPOPTS)
|
|
DFLAGS=-DCAML_NAME_SPACE -g -DDEBUG $(BYTECCCOMPOPTS)
|
|
|
|
OBJS=interp.o misc.o stacks.o fix_code.o startup.o main.o \
|
|
@@ -48,14 +48,14 @@ ocamlrund$(EXE): libcamlrund.a prims.o
|
|
prims.o libcamlrund.a $(BYTECCLIBS)
|
|
|
|
install:
|
|
- cp ocamlrun$(EXE) $(BINDIR)/ocamlrun$(EXE)
|
|
- cp libcamlrun.a $(LIBDIR)/libcamlrun.a
|
|
+ ${BSD_INSTALL_PROGRAM} ocamlrun$(EXE) $(BINDIR)/ocamlrun$(EXE)
|
|
+ ${BSD_INSTALL_DATA} libcamlrun.a $(LIBDIR)/libcamlrun.a
|
|
cd $(LIBDIR); $(RANLIB) libcamlrun.a
|
|
- if test -d $(LIBDIR)/caml; then : ; else mkdir $(LIBDIR)/caml; fi
|
|
+ if test -d $(LIBDIR)/caml; then : ; else ${BSD_INSTALL_DATA_DIR} $(LIBDIR)/caml; fi
|
|
for i in $(PUBLIC_INCLUDES); do \
|
|
sed -f ../tools/cleanup-header $$i > $(LIBDIR)/caml/$$i; \
|
|
done
|
|
- cp ld.conf $(LIBDIR)/ld.conf
|
|
+ ${BSD_INSTALL_DATA} ld.conf $(LIBDIR)/ld.conf
|
|
|
|
ld.conf: ../config/Makefile
|
|
echo "$(STUBLIBDIR)" >ld.conf
|