Bug fixes: - ocamldoc: -using modtype constraint to filter module elements displayed in doc - ocamldoc: error in merging of top dependencies of modules - ocamldoc: -dot-colors has no effect - ocamdloc: missing crossref in text from intro files - compilers: segfault with recursive modules - compilers: infinite loop when compiling objects - compilers: bad error message when signature mismatch - compilers: infinite loop with -rectypes - compilers: contravariance bug in private rows - compilers: unsafe cast with polymorphic exception - native compiler: bad assembly code generated for AMD64 - native compiler: stack alignment problems on MacOSX/i386 - stdlib: crash in marshalling - stdlib: crash when closing a channel twice - stdlib: memory leak in Sys.readdir - C interface: better definition of CAMLreturn - otherlibs/unix: crash in gethostbyname - tools: subtle problem with unset in makefile - camlp4: install pa_o_fast.o - camlp4: install more modules New features: - ocamldoc: name resolution in cross-referencing {!name}: if name is not found, then it is searched in the parent module/class, and in the parent of the parent, and so on until it is found. - ocamldoc: new option -short-functors to use a short form to display functors in html generator - ocamlprof: added "-version" option
15 lines
853 B
Text
15 lines
853 B
Text
$NetBSD: patch-bv,v 1.3 2006/10/03 21:06:25 adam Exp $
|
|
|
|
--- camlp4/compile/Makefile.orig 2006-09-12 10:58:10.000000000 +0200
|
|
+++ camlp4/compile/Makefile
|
|
@@ -30,8 +30,8 @@ $D_fast.ml: compile.cmo $(SRC)
|
|
OTOP=$(OTOP) EXE=$(EXE) ./compile.sh $(COMP_OPT) $(SRC) >> $D_fast.ml
|
|
|
|
install:
|
|
- if test -f camlp4$D.fast.opt; then cp camlp4$D.fast.opt $(BINDIR)/camlp4$D.opt$(EXE); fi
|
|
- for TARG in pa_$D_fast.cmi pa_$D_fast.cmo pa_$D_fast.cmx pa_$D_fast.o ; do if test -f $$TARG; then cp $$TARG "$(LIBDIR)/camlp4/."; fi; done
|
|
+ if test -f camlp4$D.fast.opt; then ${BSD_INSTALL_DATA} camlp4$D.fast.opt $(BINDIR)/camlp4$D.opt$(EXE); fi
|
|
+ for TARG in pa_$D_fast.cmi pa_$D_fast.cmo pa_$D_fast.cmx pa_$D_fast.o ; do if test -f $$TARG; then ${BSD_INSTALL_DATA} $$TARG "$(LIBDIR)/camlp4/."; fi; done
|
|
|
|
clean::
|
|
rm -f *.cm* *.pp[io] *.o *.bak .*.bak *.out *.opt
|