pkgsrc/multimedia/ming/patches/patch-configure.in
markd 7b73295492 ming: update to 0.4.8
7 Apr 2017 - Ming 0.4.8
* Add PHP7 compatibility
* Fix C++ output of disassembler
* Fix heap overflows in parser.c (CVE-2017-7578)
* Avoid division by zero in listmp3 when no valid frame was found
* Don't try printing unknown block.
* Parse Protect tag's Password as string
* Check values before deriving malloc parameters from them in parser.c
* Make readString() stop reading string past buffer's end
* Return EOF when reading unsigned values hits end of memory backed buffer
* Exit immediately when unexpected EOF is by fgetc() in utility programs
* Fix using EOF marker -1 value as a valid flag byte
* Fix division by zero sample rate due to global buffer overflow.

15 May 2015 - Ming 0.4.7
* Restore support for giflib 4.1.x

14 May 2015 - Ming 0.4.6
* Add support for building against giflib 5.1.1+
* Fix support for bison 2.6+
* Fix build on GNU/Hurd(PR #39).
* Fix possible buffer overflow in makeswf
* Change php bindings license from PHP to LGPL-2.1+
* Fix build of python binding with libgif (rather than libungif)
2018-11-13 10:18:26 +00:00

41 lines
1.5 KiB
Text

$NetBSD: patch-configure.in,v 1.1 2018/11/13 10:18:26 markd Exp $
From ef3719d39e8bb7e96c6ec57d60261f1516353460 Mon Sep 17 00:00:00 2001
From: Lars Wendler <polynomial-c@gentoo.org>
Date: Fri, 4 May 2018 17:40:04 +0200
Subject: [PATCH] Use pkg-config to find freetype
As of freetype-2.9.1 the freetype-config script has been deprecated and
is no longer shipped by default.
--- configure.in.orig 2017-04-07 08:12:56.000000000 +0000
+++ configure.in
@@ -257,26 +257,8 @@ freetype_support=yes)
if test "$freetype_support" = "yes"; then
dnl Check for the freetype library
- AC_ARG_WITH(freetype-config, [ --with-freetype-config=PROG Use FreeType configuration program PROG], freetype_config=$withval, freetype_config=yes)
- if test "$freetype_config" = "yes"; then
- AC_PATH_PROG(ft_config,freetype-config,no)
- if test "$ft_config" = "no"; then
- echo "To compile ming please install freetype:"
- echo " as .deb user: sudo apt-get install libfreetype6 libfreetype6-dev"
- echo ""
- echo "or disable the freetype configuration option:"
- echo " --disable-freetype"
- AC_MSG_ERROR([Could not detect freetype-config!])
- fi
- else
- ft_config="$freetype_config"
- fi
-
- FREETYPE_CFLAGS="`$ft_config --cflags`"
- FREETYPE_LIBS="`$ft_config --libs`"
-
- AC_SUBST(FREETYPE_LIBS)
- AC_SUBST(FREETYPE_CFLAGS)
+ PKG_PROG_PKG_CONFIG
+ PKG_CHECK_MODULES(FREETYPE, freetype2,, AC_MSG_ERROR([Could not find freetype]))
fi
dnl Check for the ungif or gif (new or old) libraries